FS20 stopps working after some time - need debugging help

  • Platform information:
    • Hardware: RPi2
    • OS: OpenHabian
    • Java Runtime Environment: 1.8.0_152
    • openHAB version: 2.4.0-1

I’m using OpenHab with FS20 and Sonos Binding, but after some days or sometimes weeks, the FS20 Binding stops working. I see messages like
“2019-01-05 19:31:39.105 [DEBUG] [ab.binding.fs20.internal.FS20Binding] - Received command ON for item fs20_SWITCH_wohnzimmer_chillbeleuchtung”
in the log, but cannot find any errors that might give a hint.
I tried “log:set DEBUG org.openhab.binding.fs20” which did not give much more Information and then tried “log:set DEBUG”, but I also couldn’t find any messages that look suspicious to me - but maybe I missed something relevant in the noise…

I use https://www.ebay.de/itm/nanoCUL-USB-Stick-FTDI-CC1101-868MHz-FW-1-67-FHEM-CCU-CUL-868-inkl-Adapter/372216852633?ssPageName=STRK%3AMEBIDX%3AIT&_trksid=p2057872.m2749.l2649 as FS20 Transceiver and my /etc/openhab2/services/fs20.cfg looks like:


The Sonos-Binding works fine while the FS20 problems are present. After restarting openhab with “sudo systemctl restart openhab2” the fs20 binding works again.

Would be great if someone can give me a hint, how to trace the problem!

Thanks a lot and best regards,

Hey Frank,
did you manage to find a solution for that?
I seem to have the same problem (for me it only works some minutes after a restart). I read something about nanoCul doesn’t seem to be the best option, but it does work after a restart. So I am not quite sure.

Fhem is working fine, but I would like to use OpenHab for that, without the fhem integration or something like this.

Edit: While writing this, I just got an idea about fhem is already using the Cul. After disabling the fhem service, it seems to work (currently)