Gardena: Error 429 Limit Exceeded

OH 3.3

Since yesterday I get those errors 429 from GardenaAccountHandler and the mower isn’t accessible anymore.
I thought that those problems were solved, but now they returned.
Does anybody have the same issues?

My system also went down yesterday. However disabling the account thing, and reenabling again, was sufficient to restore functionality. Maybe a server glitch?

I was wondering, because my Gardena app had also problems to send data. But disabling the account (in my case I have removed and added the binding) helped.
Now also the app can send data.
Let’s hope that it was just a temporary problem.

I just checked and I had the very same. Disabling and enabling the account Thing once made brought it back online again.
I’d nonetheless consider this a bug in the binding - if the connection can be restored by disabling/enabling, the binding itself should be able to automatically do this by itself without requiring a user intervention.


Hey everyone.
Same problem and same solution. Gardena App still works, openHAB connection not. Disable and Enable the Bridge solve this problem in my case. Thanks for the hint.

@Kai I would be happy to look at this in a couple of weeks time. Could you perhaps open an issue to remind me?

Sure: [gardena] Error 429 Limit Exceeded · Issue #13137 · openhab/openhab-addons · GitHub

Thanks, @AndrewFG!

Disable and Enable the Bridge solve this problem only for a short time. After one day same problem…

Same thing here :-/ Since now I do get the issue at least twice a day. Pause/disable and re-enable the Thing brings it back to work. At a fact: For me it’s not useful with openHAB right now as I can’t trust it will work on next morning: where I have a rule to water our lawn/garden :frowning:

@AndrewFG Crossing my fingers you will find some time rather soon (before summer ends) :wink:

Yes, I see this problem also now on a daily basis. As the binding has not changed for some weeks, I suppose the problem is due to something changing in the last few days on the server. With luck I might have some time to look at this deeper tomorrow.


Hello all

Maybe, this is because of this problem? They have changed the autentification:

See Problems to connect to Gardena cloud service with the Gardena binding

This is fixed.

Ok, just thought because I had the same problem with Limit exceed and then tried to set a new application in the husqvarna cloud and since then, I was no more able to connect with the the cloud because a Secret key is now required (see last posts of my link). I‘m on OH3.3 and there it is not fixed. I‘m currently in holiday, I couldn‘t try the new jar file, but looks like it is working with this.

FWIW, interestingly, my account is still online since I disabled/enabled it 4 days ago.

Mine went also offline again.
I got additional messages:
2022-07-22 06:46:07.207 [WARN ] [.core.thing.binding.BaseThingHandler] - Handler GardenaAccountHandler tried updating the thing status although the handler was already disposed

@Kai @Integer @INT5749 @laursen @openschwall @usambara

Dear All,

I have been looking at this today. And I can see that there is an NPE bug when the account thing fails to initialize. And also @usambara has reported a (minor) bug when the thing is disposed.

HOWEVER, these bugs are NOT the actual CAUSE of the error; they are simply fallout of what happens after the Gardena server rejects an API call with ‘Error 429 Limit Exceeded’.

Probably ‘Limit Exceeded’ means that the binding did at some time make too many (possibly bad) API calls within a 24 hour period. But the question is WHY the binding made too many calls???

The current binding code has been running on my system without any such errors since June 28th, yet now suddenly after 3 weeks of clean running, we start seeing these errors. Therefore I guess that something did change on the Gardena server side. Although I cannot confirm it. ???

Furthermore, since I had already exceeded the call limit before I enabled logging in my system, it means that I have no log of the API calls that may have exceeded the limit in the first place. Probably I have to wait for 24 hours before the limit count on the server may be reset. So the code / test / release cycle may unfortunately take quite a few days before we can get to the bottom of the problem…

=> So if any of you guys have logs that might give me more immediate clues, can you please post them here?

Suprisingly the binding is going to work right away after disabling and re-enabling, so I imagine if there is a limit exceeded at all?

=> If I would get some advise hwo to capture logs, I’m happy to help.

I’d say the first step towards a fix should be to make sure that the binding continues to retry establishing the connection after seeing an 429 and going OFFLINE. Once it does so, we would learn how long it takes after a 429 to resume operation and all of us could have a closer look at the logs and the call frequency, without ever having to manually disable/enable the Thing anymore. Wdyt?

I can confirm @Kai’s experience, but in a different scale. Service availability today is better than some days ago, but still “limit exceeded” occurs, from “offline twice a day” to “online more than 24h”. I find this on 2 openHAB instances with different Gardena accounts, at different times.
Usually, simple deactivate/activate of Bridge Thing is not good enough to get back online, even with 1h in between. A bundle:restart org.openhab.binding.gardena + de/activate of Bridge Thing helps, anyways oh-service or computer restart.

I think the problem may be that when it encounters some server error (probably initially some error other than 429), it does already continue to retry; and it does so too frequently that finally it reaches the limit of retries. I think perhaps the retries should be rate limited, maybe with a faster cycle initially and with an exponential rate back off. But first it would help to find the original cause of the first retry…