GE Z-Wave Plus Smart Dimmer 14296 and z-wave binding

Tags: #<Tag:0x00007f6184590230> #<Tag:0x00007f61845900a0> #<Tag:0x00007f6184597f30>

Hi,
I have added a GE Z-Wave Wall Dimmer 14296 https://www.amazon.com/gp/product/B08562L9RP to my setup but the binding does not appear to recognize it. The dimmer switch has ZW3011 stamped on the front which is listed as a “Supported Thing” when I search for it in paper:

ZW3011.pdf (34.3 KB)

However, this is what I get:

14296.pdf (44.0 KB)

I think the database may need to be updated for this device. Am I on the right t
rack? Where do I go from here?

I am running openHAB version 2.5.6-2 on a Raspberry Pi 4 with a Z-Stick Gen5.

Any help would be appreciated. Thanks.

These are the instructions on the device database: https://www.cd-jackson.com/index.php/zwave/zwave-device-database/zwave-device-database-guide

It’s not too hard, but you need to get an account and update the database, request approval, then it gets incorporated in the next release.

Thank you for the information, I really appreciate it I have created a database account and opened a ticket to get permission to update. I found “ZW3011” in the database:

Jasco Products ZW3011/14322/46565 In-Wall Smart Toggle Dimmer All Wall Switch

The Manufacturer ID and DeviceType match my device and the picture looks the same, however the content does not appear to be a very good match to my xml file.

network_d4143a49__node_7.xml (10.1 KB)

I am not sure at this point weather I need to upload the xml file to the database or just add the extra references to the existing device. I find the xml files confusing and I don’t want to break anything. Can someone please point me in the right direction.

Thanks again.

Unfortunately the manufacturers seem to put out multiple devices with the same external name, but the internal identification is different.

Your device has:

<manufacturer>0x63</manufacturer>
<deviceId>0x3132</deviceId>
<deviceType>0x4944</deviceType>

But the database has a different type ID. Yours has 3132 but the database has 3237.

Manufacturer ID	0063
Name	ZW3011/14322/46565
Device Description	In-Wall Smart Toggle Dimmer
Category	Wall Switch
References (Type:Id)	4944:3237

My suggestion is to create a new device in the database since it is different. You may be able to copy much of the information from the other device to your new device.

I don’t know if it is possible to have the same device in the database with 2 different device ID’s. If your device matched perfectly, then maybe that would work, but I defer to the experts on that.

If the functionality is the came, the IDs can ( and should) be added to the current entry.

I uploaded my xml file and corrected all of the errors except:

"thingid is > 15 characters - is this really necessary - it should just be the model number."

I had initially set the name to “GE 14296 Wall Dimmer” so changed it to “ZW3011/14296” but still get the same error message.

https://www.cd-jackson.com/index.php/zwave/zwave-device-database/zwave-device-list/devicesummary/1270#documents

I found this thread which appears to be the same issue and Chris fixed it from his end.

@chris Would you be so good as to take a look and point me in the right direction.

Thanks all for you assistance.

I’ve fixed the error with the thingid, but it does seem we have two devices with the same name. Are these really different?

If it’s basically the same, then we should just update the existing device rather than create a new entry. You need to compare the manuals to see if they have the same associations and config parameters - to me the device looks the same outside of this (ie the classes look pretty much the same).

1 Like

@chris Thank you for fixing the thingid. As you suggested I compared the manuals and they appear to be the same to me so I updated the entry for “ZW3011/14322/46565” with my xml file for “14296”.

The updated entry is now waiting for approval. My new entry which is no longer needed is still there as well, is there any way to remove it. ?

Thanks for all the work you do for the community. I really appreciate it.