Getting rid of Zigbee ghost devices in inbox

Tags: #<Tag:0x00007f616e827a68> #<Tag:0x00007f616e827978> #<Tag:0x00007f616e827798>

I have some zigbee devices that did not complete discovery and to sort that out I need to remove them and re-add them. Unfortunately I cannot seem to get rid of them! I delete them from the inbox (also tried adding them to things and delete them there), stop the OH service, clear the cache and start up OH again (with and without restarting the system). When starting up the devices (that are not powered) are still in the Inbox!
After a whole lot of scratching my head I found out that I did not just have to clear the cache, I had to go into the userdata folder, under Zigbee// and remove the xml-file corresponding to the ghost devices before starting up again!

I write this to help others with the same problem, I could not find anything in the forum about this since previous.
Maybe something to write in the binding documentation page? @chris?

2 Likes

I have the same problem, but deleting the xml files doesn’t help me either. All zigbe devices reappear after a short time. I think, the devices are still stored on the coordinator, unfortunately I have not yet found a way to delete them here.

Maybe, although this data store isn’t really something the user should be messing with. Ideally, if a device leaves the network, we should remove this XML. This is being improved in the latest libraries and I will try to get an updated version released over Christmas. We can then look at this issue and address how better to handle it.

1 Like

Hey Together,
unfortunately I have to dig this thread out again.
I am no OH2.5.5-1 (openhabian) and also have one ghost device.
Zigbee Binding is 2.5.5
I am not able to delete and pair it again, it Always is back in Inbox after a second.
I did the following without success:

  • Stop OH
  • delete XML in userdata/zigbee/coordinator
  • clean Cache
  • Restart pi

would apreachiate help in this case, cause I like to use this device without Setting up the wohl Network again :slight_smile:

If any logs or Information is needed please let me know

Greetings Andy

It should not matter that the device appears again. The key to pairing the device is to always reset the device - otherwise you cannot pair it again due to network security.

1 Like

Thanks for the Reply, it works now. Maybe some Kind of coincidence, but seems like i had to delete the device, pair another device and then pair the ghost defivice again… alwas resetted the device between Pairings. When I deleted the ghost device, resetted it and tried to pair again, it immideately appears in Inbox and was not working.
Greetings Andy