Getting started with Development openHAB 3 - Why can't I access paperui?


I followed this guide for development in Eclipse (I chose branch 3.0):

When I click “Run OSGi” (step 5), openHAB starts and the console shows:

> ____________________________
Welcome to Apache Felix Gogo

g! 22:42:10.687 [main] INFO  o.o.c.m.c.i.ModelRepositoryImpl:100 - Loading model 'demo.items'
22:42:11.061 [main] INFO  o.o.c.m.c.i.ModelRepositoryImpl:100 - Loading model 'mapdb.persist'
22:42:11.234 [main] INFO  o.o.c.m.c.i.ModelRepositoryImpl:100 - Loading model 'demo.sitemap'
22:42:11.375 [main] INFO  o.o.c.m.c.i.ModelRepositoryImpl:100 - Loading model 'demo.things'
22:42:12.373 [main] INFO  o.o.c.m.c.i.ModelRepositoryImpl:100 - Loading model 'demo.rules'
22:42:13.230 [scriptwatcher-1] INFO  o.o.c.service.AbstractWatchService:185 - Loading script '/C:/Users/Juliet/openhab-master2/git/openhab-distro/launch/app/runtime/conf/automation/jsr223/demo.js'
22:42:18.300 [OH-ruleengine-1] INFO  o.o.c.a.internal.RuleEngineImpl:1445 - Rule engine started.

The problem is, I can’t reach localhost with “http://localhost:8080/paperui/”. Instead I get HTTP Error 404 Problem accessing /paperui/. Reason: Not Found

PaperUI has been replaced with a new main UI. Just go to localhost:8080 and follow the setup process :slight_smile:

1 Like

Hi, in OH3 PaperUI was replaced with a renewed configuration UI. Just try without /paperui. http://localhost:8080/ Cheers Steffen

1 Like

Thank you!

Hm i thought we had catched up with most of the outdated references.
Seems i was wrong.

I have fixed that documentation part (and some others):

Using Eclipse, when I go to http://localhost:8080 I get the screen to add a new user, and after that it shows the default screen, but I’m not able to click through to add things from the, and when I refresh the page it responds but is just empty. I restarted Eclipse and get the same behavior. Is there something else I’m supposed to do? Thanks.

You might have to logon?! There is a lock-icon in the lower left corner :slight_smile:

When it shows the “default screen”:

  1. click on the 3 lines in the upper left corner. You now should see a menue.
  2. click on Settings.
  3. click on Things.
  4. In the lower right corner you should see a plus. Click on it.
  5. now you should see your binding and be able to add it.

Thanks. Yeah I had tried all that. I clicked on Things but it just didn’t do anything, and after that when I refreshed it was just an empty page (no controls to add anything). This morning when I restarted everything it just seemed to work – go figure…

This topic was automatically closed 41 days after the last reply. New replies are no longer allowed.