GLIBC update on OpenHabian

Tags: #<Tag:0x00007f61739f8040> #<Tag:0x00007f61739ffed0>

Hi there,

I am proposing to use communication using MQTT throughout my Home Automation project and have sufficient hardwired I/0 to require 2x Arduino Megas to be part of the system. All control is localised within a single cupboard in my house, so was looking to connect Ardunios to Pi with USB, whilst maintaining MQTT. For this I found a potential solution in Serial2mqtt. However during installation it was found that the latest OpenHabian (i’m using OpenHAB 2.5.5) that utilises GLIBC version 2.24, however serial2mqtt requires version 2.28, with the following message appearing:
./serial2mqtt.armv7l: /lib/arm-linux-gnueabihf/libc.so.6: version GLIBC_2.28 not found (required by ./serial2mqtt.armv7l)

So I’d like to check if any update in the build will include an update of GLIC to version 2.28 or beyond?
Or I would have to purchase hats for the arduinos to get them on the network…

Many Thanks
Dan

sudo apt-get update followed bu sudo apt-get upgrade -y did not update it new enough?

The openHABian image OS is based on Raspbian Lite Buster.

I completed the update 2 days ago, (up to v2.5.5 from v2.5.4) and the GLIBC version 2.24 remains with this latest build.

You could research how to update on Raspbian or possibly Debian. It appears they may have recently announced a newer OS (at least a different name) when they announced the 8GB Pi.

Apologies, I don’t understand that suggestion… I have OpenHABian installed, not Raspbian. How can I update Raspbain (and presumably it’s components incl GLIBC) when I have OpenHABian installed?

The OS used in the openHABian image IS Raspbian with some customizations.

OK, so is there a way to update the Raspbian? without affecting the OpenHABian install.
Basic instructions for a relative newbie (me), would be most appreciated.

Did you try the 2 commands (in that order) in my first post? That grabs the most current version of all packages for that OS. A reboot is recommended after updating.

If the commands to not put in a new enough version,. further research is needed.

I did do the 2 update and upgrade commands, but did not reboot.
I will reboot and return very shortly…

Okay completed a “sudo reboot”, and still no update of GLIBC.

[16:05:34] openhabian@openHABianPi : ~/Debug $ ./serial2mqtt.armv7l

./serial2mqtt.armv7l: /lib/arm-linux-gnueabihf/libc.so.6: version `GLIBC_2.28’ not found (required by ./serial2mqtt.armv7l)

Let me guess:
your OS is based on Stretch and not on Buster.

Distro libc6 version
Ubuntu xenial 2.23
Debian stretch 2.24
Ubuntu bionic 2.27
Debian buster 2.28
Ubuntu focal 2.30

You may check that with the command:

lsb_release -a

You may upgrade the OS with as described here:
https://linuxconfig.org/how-to-upgrade-debian-9-stretch-to-debian-10-buster
( I did not test it )

As alternative you can download the source code of teh library and try to compile it yourself as long as all requirements are fulfilled.

Or backup your configuration & install a new openHABian image & restore you old configuration.

Hi Bruce,
Thank you for your help.
Sorry, I don’t understand how install a new OpenHABian image will solve the problem as I have the latest OpenHAB version installed as updated here >

Hi Wolfgang_S,

Thanks for your contribution.

I have no idea. I completed the recommended installation on my Pi as described here

Result:
[18:05:58] openhabian@openHABianPi:~$ lsb_release -a
No LSB modules are available.
Distributor ID: Raspbian
Description: Raspbian GNU/Linux 9.11 (stretch)
Release: 9.11
Codename: stretch

Apologies for my misunderstanding, but isn’t my OS OpenHABian (based on Raspbian)?

Sounds beyond my limit of capbilities!!

What do you recommend? Thanks

That is the latest openHAB version the OS in your openHABian is old.The openHABian image with the glibc version you need was released last year.

Right - thanks.
So complete a back-up (make a copy of my config file, reinstall the zigbee2mqtt, etc), burn a new OpenHABian image (with etcher), and complete the installation on my Raspberry Pi again, right?
Then add back in my config file and redo the the zigbee2mqtt installation…?

Please confirm.
Many Thanks
Dan

@mstormi does that sound correct to you?

Nonsense. Just as linked above, upgrade to buster.

1 Like

OK, I am not a Debian guru. I use RedHat based distributions more often.

Thank you Markus, for your confirmation. I run the update/upgrade and the serial2mqtt behaved appropriately afterwards.

Kind Regards, Dan

1 Like