threads ruin my openHAB system after some days


i have the following issue:
after 2-3 days my cpu usage and system load goes up through the roof. I did a jstack of my running java process and discovered, that this usage is caused by many threads like this one:

“Thread-7737” #14681 daemon prio=10 os_prio=0 tid=0x00007fdf3805b800 nid=0x673d runnable [0x00007fdebf2f5000]
java.lang.Thread.State: RUNNABLE
at Method)

so now here is the problem: there are many topics in this community for example this one, which says that there is generally a high cpu usage with the serial binding. The solution of that high usage is to be solved in this topic. The problem is, that we don’t get the new version of nrjavaserial because of this topic.

that’s all good and i could live with it and wait until the new versions arrive, but in my system i don’t only have a little higher cpu usage, my system becomes unusable at all after a few days with 100% cpu and loads up to 20. Something seems to fill up, to run over, but i can’t identify what it is, the only thing i can say is, that it seems to be RXTX.

the system is a small mini itx supermicro board with atom processor, 4Gb ram and ubuntu 16.04 server on ssd and a small z-wave zmeeuzb1 stick.

do you have any suggestions what i could try? i love the idea of openhab and the community and there is no option to switch to another project because of that problem - please help me not to be helpless at all.

thanks & regards,

is there really no one who can give me an advice where to dig?
i’m pretty frustrated an my only solution is a cronjob which restarts my server every night and that’s far from i really want to do…

Have you found a solution for this? I thing I might have the same problems you describe.

poah i’m not sure what exactely solved the issue as i changed the hardware and the os at the beginning of my openhab installation often…