Google assistant. can not connect to openhab anymore. Oauth2 screen missing

My setup was working for months but i needed to add a new device
i unlinked openhab from google assistant and tried to link it again

Normally this is no problem and you get every device(which i tagged) back again

now i get the message Openhab connected and after a while “something went wrong, please try again”

this is driving me mad and seems to be a problem a lot of other users are having

yesterday i tried something else

i logged in google assistant(on my iphone) with A DIFFERENT GMAIL ACCOUNT and guess what, everything working perfectly

so here is the thing, with my gmail account it does not work but with the account of my son it does.

where do things go wrong?
is it at the level where my google account is blacklisted somehow(eg because of multiple logins) or on my iphone
to rule out my device i also tried my acount on another iphone and ipad, same result.
Things must be going wrong at the openhab cloud end.

i cleared out my gmail account and disabled everything possible but nothing helps

it seems like my gmail account is not accepted and i do not even get forwarded to the oauth2 screen to login with my openhab credentials