Google Assistant with Light as group

Hi,

I have been struggling with getting my lights to work with Google assistant. I have no problem with them when I simply set up an item such as a dimmer or a switch (and set them up as a light using google metadata). However when I try to group several points (brightness & colour) under a group, this group does not seem to show up in Google Home app even after syncing devices.

The way I tried to set this up was:

  1. Created “Equipment” called “Lights” and added Google metadata to it:
  2. Added points for brightness (dimmer) and colour and assigned relevant Google metadata to them:

So the overall structure looks as follows:
image
I could not find anything else in the guide that I would have to do, but this light just does not seem to show up in Google Home.

Has anyone done a similar set up and got it to work? Thanks in advance!

I have exactly the same issue and i started searching the web and openahab forum to understand if it was normal and i found your topic. Unfortunately i did not found any solution and the only way to get light working in google assistant for me has been to assign the metadata “light” directly to the dimmer element (legacy behaviour without the color control).

Waiting for someone else to reply, i would just like to pinpoint that the documentation (Google Assistant | openHAB) clearly highlight the existence of an optional lightpower attribute

but this attribute does not exist into the semantic model page

metadata

And by checking the ga documentation page for lights “Actions on Google Smart Home  |  Google Developers” it seems that the above attribute is the required one in place of the other two. (i am not saying this is the root cause of the issue but just highlighting some mismatching information)
.

thanks, best regards.

1 Like

Thanks for your response! I did notice as well that the “lightPower” attribute was missing. I actually thought it might be a UI quirk so tried to create the same items directly in an “.items” file and use the lightPower attribute there:

The items were indeed created and I can see them in the UI:


however this light group still does not appear in Google assistant / Google Home App. :frowning: I wonder if developers working on Google assistant plug in for OpenHab could comment on the root cause. I wonder if we are missing something obvious as this is a basic set up for Hue colour bulbs…

Hi. The lightPower item is not required. But you e.g. missed the constraint, the the lightColorTemperature can only be a Number or Dimmer item but not a Color.
There is a new feature currently in testing that will add support for a separate color item.

What maybe is blocking your setup is the missing useKelvin or colorTemperatureRange property on the group. Without one of those the group item can not work.

Please always have a close look at the configuration part in the documentation.

Btw. there is always a lot of manual effort required to update the semantic model entries to reflect the supported features of the integration. This is why from time to time not all fields or options might be available in the openHAB UI.

Hi Michael,

Thank you very much for your advise and apologies for missing this - indeed my mistake. I will try with this approach and post an update.

In the meantime I was wondering if you were able to clarify the situation around lightPower item. I do actually need it in my “weired” set up because power for me is controlled via a Fibaro switch whereas everything else (brightness, colour and light temperature) is controlled via Hue once the lamps are actually on. Do you know if there is a plan to add the “lightPower” attribute to the UI so that I do not have to create these items manually?

Ok… So thanks to Michael I have worked out what I was doing wrong. In a nutshell here is what I have done:

  • It appears that I was confused and lightColourTemperature should actually be used with colour temperature and not colour :slight_smile: So I changed the setting here:
  • I also managed to add the “lightPower” Google Assistant metadata by manually changing the code rather than selecting from a drop down:
    image
    which then correctly shows up on the item:
  • Unfortunately I could not get Michael’s suggestion with “Use Kelvin” to work - the light actually showed up in Google Home app once I applied this setting but I could not change the colour temperature - Google just kept responding that the device did not support this function. So instead I switched this setting off and input the light temperature ranges:

This has now done the magic and I can control power, brightness and colour temperature of my light both from the app and using voice. As Michael suggested, changing bulb colour appears to be not supported yet (which is a shame but hopefully will come soon) :slight_smile: