Google Assistant Won't Connect

Tags: #<Tag:0x00007f434866e148> #<Tag:0x00007f434866e080>

Hi All,

Sorry for the long post, trying to give all the details here and hoping someone can please give me a little help on something driving me NUTS for two days now and before I chuck this whole thing!

  • RaspberryPi 3
  • Openhabian install with Openhab3, main stable branch
  • Everything is up to date

I have had Google Assistant working on my pretty basic setup for a while now and have not messed with it too much at all. Yesterday I wanted to add a few items that I never added back after I had to rebuild everything, corrupt SD card, and opened the openHAB app on my Android phone.

It was not connecting and messed around with getting it to work and at one point just gave up.

Later I asked Google Assistant (GA) to turn on a light and got the unavailable message. Usually, a restart of the Pi fixes that but not this time.

At this point I checked and the service is running, the Items all have the GA Metadata there, all of the Items are exposed in the openHAB Cloud, and it’s all the same from before I tried to get the app to work.

Today I did get the app to connect, locally but not with the remote server. I’m not sure I ever set that up correctly as I don’t ever recall using it but the settings are not holding with the ‘Remote server URL’ keeping the port 443 on the end. I am however able to log in on my PC in Chrome with no issues and see my system online and it all looks fine.

So my issue is that when this has happened in the past I sometimes have to go on my phone into the Google Home app, go into ‘Linked Services’, unlink the openHAB service, and re-link it again. Easy as can be and done so many times it usually takes me less than a minute.

This time I unlinked it no problem but when I try to link again I get this looking like I am about to get the OAuth2 prompt then I get this message.

I have deleted my Home in the app and completely rebuilt it, changed and double-checked my passwords on https://myopenhab.org, undid all the GA Metadata tags on all my Items, and a few other things I am sure I am forgetting.

I have Google’d this issue and searched for it here as well and I do find some posts about this “Couldn’t update the setting, Check your connection” issue and most of what I found were older and involved setting the ‘ga’ tag to expose the Items, I am not even able to get to that point. Note that everything is still controllable in the open app and in the interface, just not in the Google Home app or by voice commands.

I am at my wit’s end and if anyone could please shed some light on this, has a suggestion, or anything to get this working again, I would greatly, GREATLY appreciate it.

Since this seems to be a Google Home issue there may be a log in openHAB that may show this but I am not sure what log, none of the usual logs show any issue.

Thanks in advance!!
Dave

I’ve experienced the same problem recently but my Google Home setup is so hopelessly broken right now I can’t offer much additional information.

However I can say that the link and sync will not work unless you have at least 1 Item tagged with GA metadata. Since you removed all the metadata, it won’t work until you add it back to at least one of them.

Thank you, Sir! I just added the Google Metadata to a few objects and will let that propagate for a bit and try again. I have had this system since day one in my new house 5 years ago, going without shouting at lights to turn on is driving me batty trying to figure out where and which switches do what!

Good luck with getting your setup back in order!

Dave

Nope, been exposing a few more Items all evening and still have this problem. Anyone have any suggestions?

Thanks, Dave

So still the same thing and driving me insane! I have deleted the Home in the app and rebuilt it, unlinked all the other accounts, uninstalled and reinstalled the Home app, verified my UUID and Secret, deleted and reregistered the myopenhab.org account, and STILL getting this same issue.

I also am having an issue with connecting the openHAB app to connect using the Remote Server URL. I have the URL set to “https://myopenhab.org/” but I thought it should have :443 for the port on the end, every time I add that it disappears.

The username and password are the same as the ones I use to log in via my PC in the Chrome browser if that matters and I can get in fine.

Is anyone else having any issues linking to openHAB in their Google Home app?! Short of nuking my entire Pi build, the myopenhab.or account, my Home, and the Google app, and starting EVERYTHING from scratch which I really, REALLY do not want to do, I am at a loss.

Thanks, Dave

As a follow-up I was able to get the hHone app sorted out. I readded openHAB and it initially said it failed. But all my devices showed up anyway and they are working.

Same probems here. Count not sync anymore, removed openhab account in the google home app. After that unable to re-link the account again (to google home). error : “Couldn’t update the setting, Check your connection”

Following things helped not:
0) Any non openhan account is working fine (hue, foscam,…)

  1. re-entering UUID + secret in https://myopenhab.org/account
  2. home.myopenhab.org is working in the browser from external to internal
  3. I have 1 “ga” tag as metadata (confirmed in jasondb)
  4. removed account in https://myaccount.google.com/accountlinking
  5. removed applications https://myopenhab.org/applications
  6. Also a wierd behavior with the openhab android application (normal and beta), the external server configuration is not working like it should be, i am using the workaround. Using https://user:passwd@externalIP:port, since seperated user and password fields are not working. https://myopenhab.org/devices is empty since i use the workaround i guess

Anybody any idea how to troubleshoot this ? out of ideas to get openhab account linked again with google home.

GREATLY appreciated

Raspberry Pi 4 running Openhab 3.0.1

did you try https://user:passwd@externalip:port already

I should maybe note some of the things I did to solve my other Google Home app problems which may have helped here.

  1. Make sure all updates are installed.
  2. Force close the Home App.
  3. Restart the phone.

All of the above (sometimes more than once) was done before I readded openHAB.

Note that the problem I was having with Home that I’m still trying to solve is my Nest Hello is not showing up. In the process of trying to fix that I created a new Home. And I neglected to remove my family members from the old one before I deleted the home. So my wife’s account was still linked to openHAB in the old Home and that prevented me from adding my own link to openHAB in the new Home. I kept getting “Only the person who linked the account can sync devices.” Once I got her phone, removed the link to openHAB and fully deleted the old home was I able to add openHAB to the new Home and sync devices.

But like I said, when I linked the account I got a failure message on the link and I got a failure on the sync from openHAB. My struggles with the Nest Hello have made me become very deliberate now. So I went back to add devices and openHAB appeared at the top listing the seven devices I’ve shared with it. Looking back on the control page in the Home app showed the devices at the bottom. And they all worked.

So always, even when it says it failed, double check. It might have worked.

Indeed different problem statement. No expirience with that one.
Force close, re-install home app, reboot, tryd it all. Still wondering it has something to do with the fact that an openhab 2.5 account was linked to the home app in the past, and still keeps settings alive in the google account, not sure. I will try to install it on another phone with other google account and see if that helps. If not, clean install again will be the only option i believe.

ARRRRGGGGGG!!! I have been ignoring this as I have spent way too much time on this but just now tried it. I got the OAuth2 prompt and was super excited! I set it to allow and it went back to the Home app, it says 'Linking your account, aaaaand… same damn error.

I am going to figure a time to completely redo my Pi from scratch and see what happens after that.

Is anyone out there with a working Home integration brave enough disconnecting openHAB in the Home app and seeing if you can re-link your account?

I seriously doubt that there is anything on your service that is related to the error. So long as you have the cloud connector installed and configured with myopenhab.org and at least one Item has GA metadata that’s all there is to it. If there is an error it’s likely something messed up with Google Home (in my experience it’s a very finicky app) or the myopenhab.org service.

But also pay attention to my warning above. You may get the error but did you actually do a refresh and sync to verify? When I relinked my account I got the error too, but it worked despite the error message.

Just a quick explanation about how the Google Cloud connector works which i hope will save people some time when troubleshooting.

When you link your google home account to your OH instance, the connector does 2 things.

The first is to initiate the linking process / oauth flow. This is how the connector gets a token from myopenHAB to talk with your OH instance. Your OH is not used at all in this step, this is completely between myopenhab and google.

The second is that once the connector has a token, it uses that to request https://myopenhab.org/rest/items to get a list of all items on your system and start looking for ones that are tagged correctly.

Thats it.

If your are tying to trouble shoot this, and have already completed authenticating the connector with myopenhab, then the next step would be to check the output of https://myopenhab.org/rest/items (once you log into myopenhab of course) . If you are getting what looks like valid JSON back, then you next need to check your item tagging and configuration.

You should not need to rebuild, reinstall, or generally do anything drastic to your system to get this working :slight_smile: Hope this helps

1 Like

I just unlinked my account, Added back the openHAB app, authorized with myopenHAB, and it found all 75 devices i have exposed to it.

Thx, for this insight, really appriciated. This is really helping trouble shooting.

I am using openhab 3.0.1 without textual files, in the user interface I added 2 items that do contain metadata to GA “value”: “Switch”. I checked these references are stored in JasonDB in “org.openhab.core.items.Metadata.json” and not in “org.openhab.core.items.Item.json”.

https://myopenhab.org/rest/items is working fine. All items are returned but no references to Google Assistance.

Also REST https://myopenhab.org/rest/items/yourIitem does not return GA references

{“link”:"https://myopenhab.org/rest/items/yourIitem",“state”:“OFF”,“editable”:true,“type”:“Switch”,“name”:" yourIitem ",“label”:“Drukknop Luidspreker Bureel”,“category”:“wallswitch”,“tags”:[],“groupNames”:[“Equipment”]}

It looks that https://myopenhab.org/rest/items returns straight “org.openhab.core.items.Item.json” without the merge of the metadata in “org.openhab.core.items.Metadata.json”

So it needs to query also the metadata or the GA app will never find items configured for GA, correct ?

https://myopenhab.org/rest/items/yourIitem?metadata=ga is working fine, but still GA app will not connect to openhab.

Hello,
i have the same connection issues. I followed the steps from Stephan_Kotleven a can say i have the same results.

I also tested it with a textual .items file with just one GA Switch Item.

A few month before i had no issues with that.
Something must have changed so that there is no connection possible anymore.

https://myopenhab.org/rest/items :

{“link”:“https://myopenhab.org/rest/items/testswitch",“state”:“NULL”,“editable”:false,“type”:“Switch”,“name”:“testswitch”,“label”:“Switch”,“tags”:[],“groupNames”:[]},{“members”:[],“groupType”:“Switch”,“function”:{“name”:“OR”,“params”:[“ON”,"OFF”]}

https://myopenhab.org/rest/items/testswitch :

{“link”:“https://myopenhab.org/rest/items/testswitch",“state”:“NULL”,“editable”:false,“type”:“Switch”,“name”:“testswitch”,“label”:“Switch”,“tags”:[],"groupNames”:[]}

https://myopenhab.org/rest/items/testswitch?metadata=ga :

https://myopenhab.org/rest/items/testswitch",“state”:“NULL”,“metadata”:{“ga”:{“value”:“Switch”}},“editable”:false,“type”:“Switch”,“name”:“testswitch”,“label”:“Switch”,“tags”:[],"groupNames":[]}

My .items file look like this ( All other Metadatas over the UI to other Items are already removed:

Switch testswitch “Switch” { ga=“Switch”}

After invesrtigating some frustating time on this problem i figured out a solution thanks to an old thread:

https://community.openhab.org/t/solved-google-assistant-couldnt-update-the-settings-check-your-connection/64193/10

It seems very important to give every item a label. I just did that with my countless items just to give it a shot.
In Openhab 2 with textual files it was more intuitive to give every item a label especially with the use ofe BASIC UI. But in Openhab 3 over the UI it is easily left empty because there is not much need for it.

To my amazement that solved my issues with this “Check connection error”. Hope this will solves also for others these frustating problem/bug.

Hi Dominik would you mind showing me how you have one item labeled please? I am still having the issue and coming back to this as I was beyond frustrated with it. I am going to look at my setup when I get home in a few hours and would like to compare your labeling format to what I have, or at least think I have at this moment. Thanks!

Dave

Hello. I just give every item a label name in the items settings. Before i left some items blank because i didnt need everywhere a label for an item. Thats all i did. One minute before i retried to sync my devices and it still works without error.

Thanks for posting that Dominik, still didn’t work for me.

I know this should not have anything to do with anything but I just wiped my Z-Stick and created/installed a brand new instance of openhabian on a new card and I can now connect with no issues.

This was my last-ditch effort to tey to get this to work before I looked into another solution and ditched openHAB.

I appreciate everyone’s help though and just wanted to say thanks!

Dave