Google Calendar Scheduler "not found"

I set up the Google Calendar Scheduler to use for determining days when my wife or myself are at work. For some reason it is not finding the calendar.
I created a new calendar to use specifically for the scheduler. I’ve recreated it about three times actually. I’ve enabled Trace logging, but the only relevant info I get is this.

[WARN ] [] - Calendar OH not found

I tried changing to the default Work calendar then I get this.

gcal feed contains no events ...

So it appears to be working, just not with any newly created calendars.

Well I feel like an idiot. Restarting OH, rather than just the addon fixed the problem.
I will leave the post as a reminder to try the simple things first. Even if you don’t think they will make a difference.

And here comes the thanks of another “idiot” who spent an evening creating and removing Google calendars trying to fix the calendar not found warning.

After finding this post a quick

systemctl restart openhab2.service

fixed everything!

Can I suggest that you mark this post Solved and I’ll try to add a note to the gcal integration page. That way we can maybe help any other “idiots” out there.