Google Home - OH3 link no more working

  • Platform information:
    • Hardware: PI3 B+
    • OS: openhabian
    • openHAB version: OH3
    • Google Home Mini

Hi all, I have a complex system running for many years, connected to both Alexa and Google Home for voice commands.
Yesterday suddenly the link between Google Home and Openhab was broken. I tried to restore it in every way, Google Home seems to connect to Openhab, but the Google Home app always replies that Openhab has no items enabled. Obviously this is not true, as it worked well until yesterday. I tried to reset google home mini, delete the account, room, google app, restart the PI, router and all possible devices, but I always face the same behavior and now I do not know what to do.
I don’t know why it happened, the only possible reason could be that at the same time I was trying to connect a new LG TV (with LG ThinkQ) to Alexa, I don’t understand what matters for openhab and google home, but I really don’t know what to think.
Any idea?

You likely need to replace tags with metadata.

Thanks for your suggestion (also if I do not understand this sudden change in the system behaviour). As a matter of fact in a recent past I tried to move to metadata, but I faced some syntax issue, in order to combine metadata with Alexa tagging and channels. For example can you show me how should I change the following item definition

Switch BedroomLampSwitch550 "Bedroom Lamp"  ["Lighting"] { channel="mqtt:topic:MqttMain:MqttBedroomLampSwitch:BedroomLampSwitchChannel"}

Thank you

Alexa also uses metadata now, per the documentation. So:

{channel="", ga="", alexa=""}

Then you just remove the old tags, which will be ignored when there’s metadata.

The reason it changed suddenly is that you didn’t refresh your devices in Google Assistant until yesterday, even though the tags were removed months ago. So the devices continued to work.

Wow it works, without your help I would still be banging my head. Thank you very much