Google Home won't link

I tried this but i am getting error 404 item not found and 405 item not editable. Please kindly help me with this. I hope you do the needful

I did not find my next finds in this specific writing.

I want to share this extra info.

Without TAG-ging the items first, google-home will not link successful because pointing items to the correct room is part of the linking process. Without the TAG’s. it will authorize and you will return to the page where you can choose to add a device like nothing happened.

Now i know why. But because it was the first time i thought i will tag the items afterwards. This must be a logical option cause you never know what you’ll add in the future, right? Well through my experience this wasn’t entirely true lol.

Anyway tagging the items with “switchable” REST was the only option. after that linking google-home with openhab went fine, now it continues with the “point your items towards a room” screen. Otherwise it did nothing no message you just go back.

Hope i could help. Cheers!

I think it´s mentioned in the docs (where ever it is these days), that there has to be at least one TAG, before the google assistent will acknowledge the connection…

Thats so true so many shredded info everywhere. But now it’s so easy. I created an switch item called" Kodi. Tagged this item Switchable. Asked google “sync my devices” Created a rule when this item is on then Item: KODI-CONTROL: PLAY (otherwise stop) and it works. And created another rule when play turn off certain light-things. Then when asking turn everything off. then we have a problem haha. But then i just created an item called "everything (in my case “alles”). Asked google to sync again, and only added those things to this item i want to turn off or on when asking turn on/off everything. And luckily the tagged items has a higher priority then build in commands. I’m really having fun here! 3 weeks ago i didn’t even know what openhab mqtt was. It’s highly addictive.

ok I made a test because I had the same problem with connect google home with opehab.

Switch kitchen “kitchen” (all,balkonia) [“Lighting”] {channel=“mqtt:topic:0b11193a:lamps:kitchen”}

this is right because it has the name (“kitchen”) of the item.

Switch kitchen (all,balkonia) [“Lighting”] {channel=“mqtt:topic:0b11193a:lamps:kitchen”}

with this syntax cant connect and raise connection error while connecting or syncing.
Hope it helps.