Google Home won't link

Hi, I’m new trying to setup OpenHabian.
I’ve manage to create z-wave controls which are working through the cloud, but when I trying and link google home to myopenhab it fails to link. I get the OAuth2 application authorization screen, click on allow, google home appears to be linking, but fails. Openhab doesn’t appear as a linked service :frowning:

Any help appreciated.

1 Like

Please follow the how-to video guide I’ve created here: Google Home & openHAB connection How-To

and let me know if you have any issues still. Couple main things to keep in mind:

  1. Make sure you only have “Lighting” or “Switchable” tags set for your items
  2. Tell Google to “Sync Your Devices” after a successful link, just in case it didn’t pick all of them up.

Thanks heaps for the reply, I’ve watched the video, but I can’t find the file “home.items”. Do I need to create this file? I added my z-wave items using the paperUI. When I navigate to the items directory -> \\openHAB-share\openhab2-conf\items it’s empty except for the readme file.

Ahh, so you’re not using actual config files, just items defined in the database. Which is fine, but you need to add tags (Lighting or Switchable) to the items in your database that you want to link with Google Home. You can do this via the REST API - go to your openhabian main page (usually http://openhabianpi:8080 ) and click on the REST API tile. You’ll need to expand the items menu and find the “PUT /items/{itemname}/tags/{tag}” line, and expand that as well. Here, you need to know the item name and apply the tag you want to it:

[ "Lighting" ]
[ "Switchable" ]

I will recommend that in the long run, you should create an .items file for at least those items you want to link with Google Home. It’s simple, there are lots of examples here on this site and on the OH documentation wiki, and having a discrete file has always been preferred for backup/restore ability.

1 Like

I have this problem although I’m using the items file. After I tagged the items I was able to sync. Then google was saying there was a problem syncing with openhab. Hoping to solve the problem, I delinked the 2 accounts and then tried several times to re-link them (from Home app). Unfortunately I am unable to. After authenticating on and click allow, I get an error “Couldn’t update the setting. Check your connection”.

Thanks. Problem is I got stock with re-linking :slight_smile:

Then I got my answer. This is exactly the same behaviour that I’ve been having. I’m just a little shocked that nobody else has reported issues regarding google assistant integration for openhab :confused: Then most likely there is something wrong with the service :thinking:

So, I figured it out. It seems it is a problem with my items file. I tagged the dimmer devices (IKEA bulbs) with lighting and since then Google wasn’t able to sync anymore. Then wasn’t able to link (after I de-linked it). As soon as I removed the tags it successfully connected and saw all my tagged devices (for now switches). So it was a tagging issue that has an improper error text.

Indeed, as of right now, you’re only allowed to use the two tags I listed above (Lighting or Switchable)…any misspelling or any other tags used by Alexa or other bindings will cause linking issues. This is a known issue and already fixed in the latest action (which has not been officially approved/released by Google yet). For now, the workaround is to only use the two tags above, but soon, this should be resolved.

Thanks for clarifying this! :slight_smile:

@sjef86. I definitely agree something must be wrong with the service. I can’t connect at all to google but ifttt and Alexa work.

I am trying to figure out how to debug the issue but can’t seem to get any assistance from google.

@bedo2405. Same issue have you got yours working?

Hi Danny,

Yes, I have mine working again now. It was a strange behaviour, and I felt like there was something wrong with the service. But I followed some suggestions on this forum, and the GH was syncing again.

this is what I did:

*Remove all items-files. (copy to a backup location)

  • Try: “ok google, sync my devices”
  • If that’s a success, Paste 1 by 1 items file back to openhab items folder, and try to sync in between each file.
  • If you get to a point were syncing failes again, you have a typo in your items file (tagging).

Hope this helps


1 Like


I just started using openHAB about 2-3 weeks ago and in that short time, I’ve been able to install Openhabian on a Pi3, patch OH with a daily release, setup my DSC security system, Nest thermostat and camera, an Olimex PIC-WEB (PIC 18F67J60 microcontroller with a TCP/IP stack) which controls a D.C. motor using pulse width modulation (PWM), built a weather widget, added InfluxDB and Grafana to graph my Nest thermostat statistics (very cool) all using HABPanel and the PaperUI. I also got the cloud service working so I could send notifications, using rules.

The other day I set out to install and integrate Google Home and ran in to some problems. I figured out how to add the tags I needed, using the REST API, expose the items using the cloud service config option, but I was having difficulty getting my items to appear in the Google Home App. I kept getting the error message, ‘Something went wrong’. I could see the items in my cloud account, but they just wouldn’t show-up in Google Home. I searched and searched this forum, full of great information, but I couldn’t find a solution. I did see that quite a few people were having the same issue. Well, it’s painfully obvious now, what I didn’t do, but I looked into and tried so many things, I just overlooked it.

I had the mode set to Notifications only, from when I setup it up to send rule based notifications. As soon as I changed it to the Notifications and Remote Access, my two WeMo Insight plugs showed up in Google Home. I told Google to sync. my devices and just like that, it worked.

I also would like to mention, that over the next semester, I will be using openHAB to develop course curriculum for some IoT courses we are implementing at the college where I’ve been teaching for…30+ years (wow, where does the time go? I learned CP/M when I was a student! lol), so, if anyone has any projects they would like to share, I would be more than happy to incorporate them, with full credit of course. As it stands now, in just a few weeks, I’ve learned enough of openHAB’s great features to develop at least one whole course, maybe two! A testament to all the contributer’s of openHAB! :smiley:

As a new member, I can only post one pic. per post. Here’s a pic. of my HABPanel interface. It’s not pretty, yet, but I did get dynamic icons working.

Guys, if you are facing trouble in linking openhab with Google Home especially after unlinking, then have a look on to Openhab Tips & Tricks - Hobbytronics PK

hey guys,
I´m having problems with google home connecting to openhab.

I read a lot in couple of threads and tried many of them. I couldn´t solve the problem by my own for the last 5 months. Maybe you can give me advice what to do to get it working.

My openhab server has working items with tags. I added items like xiaomi vacuum cleaner, Fritzbox, camera, smartphones, chromecast, google home - all working and showing in my sitemaps. But unfortunately no connection to google home app as I could use those items by telling google.
Of course I have a working myopenhab account. I tried it thru phone on cellular network and I could control everything within the openhab app on android.

This is my openhab configuration:
-openhab 2.5.0.M1 (also had before 2.4 stable, same problem) on a Gole1 (intel atom Win10 computer) installed with the .exe like the documentation is telling
-Java 8 platform by Zulu8.25.0.3-jdk8.0.153-win_i686
-installed add-ons: Astro Binding; Chromecast Binding; Fritzbox TR064 Binding; Network Binding; Xiaomi Mi IO Binding; openHAB Cloud Connector; REST Documentation; Basic UI; HABPanel; Home Builder; Paper UI
-services openhab cloud -> mode with remote access; items to expose ->all
-set language to English

configuration in google home:
-tried language in German and English
-no devices added for now

For testing and connecting google home I deleted all my items and sitemaps and made testfiles like this:


Switch Testlight "Test Light" ["Lighting"]


sitemap Haus label="Hauptmenue"
    Frame {
    Switch item=Testlight label="Test Light"

I also tried [ “Lighting” ] instead of [“Lighting”] and also [“Switchable”].
In sitemaps and on my smartphone within openhab app I can toggle the Testlight switch. It also gets registered in Event log on myopenhab. So everything works fine…

I deleted all previous Applications on and started to add openhab in google home app. I can log in and grant OAuth2, but then nothing happens any more. Tried it 100 times, deleting applications on myopenhab and reconnecting, saying “OK google, sync my devices”…nothing. Always tells me that I have no devices yet.
Its really frustrating and takes all the joy a smart home should give.

Besides for some reason my openhab server crashed 2 times like every 2 months and I couldn´t start it again, although 10 min earlier I was able to reach it, so had to make a clean install and copied the conf files I backed up. Can´t guess why.

I hope someone has some suggestions for me.

Thanks in advance and thank you for being such a great community.

See this list, it was 12 months ago so it may have changed with any updates since then…

Thank you @matt1 for responding, I checked and everything fine. I solved the problem somehow: I just tried my girlfriends phone, a Samsung S8, and I could connect to openHAB and ad things…so weird , didn´t change anything else. I´m using a Oneplus 3 with Lineageos 16. Could this really be the reason, why I cannot connect?
Well now it´s working and I stick to this solution. Maybe this can also be a recommendation to try use another phone from home members.