Google Home works with Chromecast binding

Probably common sense (since it’s based on Chromecast technology) but I haven’t seen it mentioned yet so I figured I’d put it out there.

Google Home works with the Chromecast binding. I haven’t fully tested it, but it does allow the Home to be listed as an audio sink and you can push TTS messages to it. One weird thing, on my first message there was a chime tone before the message was delivered, on subsequent tests the chime did not sound.

The documentation should be adjusted I guess to list support of Home.


Could you share your details? I recently got a Google Home and have been trying to figure out how to connect it to my Openhab2 system.

I am really interested in setting up a TTS rule where if I turn on the light it will speak a message to you or play an audio file.



Via Paper UI…

  1. Install Chromecast binding.
  2. In inbox, look for your Home and add it.
  3. In Configuration>System>Audio make your Home the default audio sink
  4. Add a say command to a rule.
say("This is a test.")

This is assuming you already have a TTS installed and set up such as VoiceRSS. If you need help with that let me know but it’s pretty easy. Install the VoiceRSS binding, go to the VoiceRSS website and register and get a key and then add it to the binding configuration (under services).

Install Chromecast binding - check
Add Home in Inbox - check
Make Home the default audio sink - check
Enter VoiceRSS api key - check
Add say command - check
TTS via Google Home - FAIL :angry:

I added the following rule to my rules file.

rule "TTS Test"
   //Time cron "0 55 20 * * ?"
   Item sKitchenLightStatus received command OFF
   say("Hey, who turned out the lights?")

But for some reason, nothing plays. Neither the events log nor the openhab log show anything about the say command. The event log has the switch changed but nothing else. A few times I got a noise blip from my Google Home when I turn the light off but no TTS sound.


Hmmm… I’m not at my home computer now. Is there a setting in Configuration>System (maybe in voice or audio) to set VoiceRSS as the default TTS? I think you need to set the service as default and the voice you wish to use. I’ll try to help more tomorrow when I’m home.

I was just playing with this.
I can only get it to work if i set the DEfault voice in PaperUI to be "cmu-slt-hsmm - English ( United States )"
None of the VoiceRSS ones work ;-(

Edit: Scratch that… I hadnt added my API key from VoiceRSS into the binding.

It now works!

1 Like

Same here… pretty simple to follow and get setup.

The only thing that I am not happy about is that it seems that when it activates TTS, any existing application stops. So, if I am using it to play music, the music stops completely when it says something.

Is this how it is working for others?


i tried this also with OH2 but it failed…Only thing i get is this:

[ERROR] [.script.engine.ScriptExecutionThread] - Rule 'Test1 ON': null

Any ideas?


For your information, I recently added a patch to the chromecast binding that should make it return to its previous activity after playing the notification.
Should be included in recent mightly builds.

Thing was not online…

Now it works BUT: The voice ist playing way to fast… Can not understand a single word.


What TTS service are you using and what language? I remember seeing some posts from people with similar issues. I believe it was with Mary.

it was indeed Mary. I switched to VoiceRSS now and it works perfektly :slight_smile:

Are you just using the Home as a TTS device or is it working fully as a chromecast audio?

Mine was recognised by the binding but the Item is stuck on Initializing.

I think I am in a similar boat to you, Stephen. I can get an initial blip noise from my Google Home but the say command doesn’t work. Nothing else works after that.

I have voiceRSS api key entered, my Google Home as my default speaker, VoiceRSS Text to Speech Engine, VoiceRSS US English as the default voice, and Rule based Interpreter all set up.

Have you ever solved the issue? I am having same problem.

Please post your SetUP and the logentries you get while trying to get a Feedback. Are you using a rule or are you trying it from the Karaf-Console?
I’m using different audio-sink, including ChromeCast, and it is working with all of them.

I have the same issue, the playSound or TTS does not work through my mini google home. I can confirm that if I set the audio sink to web audio, it will play through my browser.

In addition, I can also play an mp3 through the Chromecast ‘play URI’ channel directly.

rule "TTS Test"
	Item TTS_TEST changed from OFF to ON

Fixed. The chromecast binding settings callback url was wrong. Needed to be like - . thanks to this thread for the tips Google Home Goes 'Offline' and audio sink doesn't work

1 Like

@Lolodomo Everything here is working perfectly. VoiceRSS works great and is triggering from rules to all of my Google Home Mini’s, but when audio is playing and is interrupted to say a command from openhab it does not return to the audio that was initially playing. From your reply it seems that you fixed it in Feb '17 but it is not working for me.

Can anyone tell me how to TTS to a specific google home mini? I want to be able to send different things to different minis