Google Integration Failing

The last couple of days, “Sync My Devices” has been failing to find OH.
Last Night my linked OH devices stopped responding to GH commands.
I unlinked the Service, now when I try to relink I get the old “Couldn’t update your connection” message.
I have tried …

  • Stopping OH, clear the caches, start OH
  • Stopping OH, move all Items files, start OH
  • A different Android Device

Nothing in the logs that indicates anything sinister, connection to the MyOpenHab appears fine.

Any suggestions on what else I might look for / try please ?

Cheers, Dave

I’ve lost connection with Google after installing Google calendar binding. After uninstalling it again and reboot all works again. Strange things happens…worth a try.

Note: Google TTS had issues. Can’t definitely say if whole Google connection lost. Using not so often my Google Home.

Thanks Herbert, I just tried that, but no luck :frowning:

Any thoughts please anyone?
I ve tried removing all my things, rules, everything…
To no avail :frowning:

You need to have at least one items which has the GA tag, otherweise it wont sync.
So remove all items except one, and then try again. If/When it works, add items untill you reach the issue again. Then you´ll know.

Hi Kim!

Thanks very much for the advice, which I’ve tried (to no avail so far).
I have removed all configuration, and currently only have a sitemap which contains -

sitemap bnis label=“Dave’s Home Automation” {

    Text label="Garage" icon="garage"{
            Switch item=GarageLights icon="bulb" label="Garage Lights (Sonoff)"


And an Items file which has -
Switch GarageLights “Garage Lights” (gKitchen) { ga=“Switch” }

The logs are showing no errors when I restart the service, but I still get the same error message when I try to link the Openhab service into Google Assistant -
“Couldn’t update your Setting. Check your connection.”

I’ve tried unlinking and relinking other providers with no issues, stopping the Openhab Service, clearing cache and tmp folders, rebooting the system…

Is there anything else I would need for this very minimal config?

Best Regards,

Are you certain that the Cloud Connector is working? Easy way to check is to open myopenhab and see if your system shows up as “Online” in the top menu of the dashboard.

Assuming that it is working (I’m just ruling it out to be certain), this may be a problem on Google’s end. I feel like there have been a few recent posts about Google not being able to connect to the OH service or sync devices.

Hi Russell,

Yes, that is working fine, and updates to items etc are reflected OK online.

I’ve just started a completely clean install of openhab…I’ll update with progress :slight_smile:

Well, that worked…

But I really don’t know why…

I’ll start adding my config back in and see if it breaks again!

Thanks fo your advice everyone, much appreciated.

Cheers, Dave

Yeah, that is pretty weird. Maybe something was preventing your item updates to push through to the cloud?

Glad you got it working again, but sorry that you had to do a clean install.