Grafana: No datapoints


(Hans) #1

Hi all,

I have a smal problem with Grafana and InfluxDB, but this makes me not being able to draw graphs.

My database has content, see the following image:content

But there are no datapoints available for Grafana, see the following image:

I followed this tutorial here InfluxDB+Grafana persistence and graphing

Do you have an answer here? I assume it has something to do with the timestamp of the database entries, the example of the sine_wave in the tutorial works like a charm


(Marianne Spiller) #2

Hi,

is it really a FROM autogen?
At SELECT, I’m using field(value) and mean() - removing mean() results in empty graphs :slight_smile:
11

Cheers,
Marianne


(Hans) #3

Hello Marianne,

thanks for the reply! It should be autogen, because influxdbs’ standard value is autogen and i did not change it. but i tried, as you suggested, also default, with same result. anyway, grafana offers me only autogen when i select a value in the “from” list.

maybe some other tips?


(Jostein) #4

Have you setup grafana as image below?
image


(Hans) #5

Hi there! Yes, setup is like that.

yes

I found something else, and propably this has something to do with the issue. See the following picture from the query inspector:

All the data has only a timestamp but no axis value. Only “null”.
Do you know why?


(Jostein) #6

That maybe the reason, mine look like this:


(Hans) #7

i think i found the reason for this issue, i played a bit with grafana and found out that inside my database there are only very few data, meaning a lot of values with “null” and only a few with real data.

i played a bit with the time range and found a graph like this:

Is this related to my strategies in the persistence file? mine looks like this:

what is yours?


(Jostein) #8

Nice!

Maybe you have to have every minute.
influxdb.persist:

Strategies {
everyMinute : "0 * * * * ?"
everyHour : "0 0 * * * ?"
everyDay : “0 0 0 * * ?”
}

Items {
Temperature* : strategy = everyChange, everyMinute
Strom* : strategy = everyChange, everyMinute
Lys* : strategy = everyChange, everyMinute
}