Grafana won't start anymore after update to 8.5.0

After latest update of grafana to 8.5.0 the grafana-server failed to start

Shortcut to solution:

First of all this is my actual first post so please be patient with me if there is something wrong.
Also it is written by a beginner for beginners :slight_smile:

I encountered today the issue that my grafana-server is not anymore reachable (“IP-adress”:3000).
Did some research via Putty on my RPi3 with OH3.2.0 installed with the following command:
systemctl status grafana-server
[…]
Grafana-server Active: Failed.
[…]
Thus did some research and found a work-around so far. Don’t want to take any credits for NOT my work so here are the link: grafana-server doesn't start after recent update to 8.5.0 on openhabian · Issue #48130 · grafana/grafana · GitHub

2 Likes

Hi Ben,

Thanks for posting this. I have the same problem.

I tried to re-install Grafana via “openhabian-config”, but this stopped with an error message.

Therefore, I installed my last backup and apt-marked Grafana as “hold”.

1 Like

now it works again with just released grafana version 8.5.1!

i am with openhabian, started openhabian-config and selected upgrade. then automatically installed grafana 8.5.1 over 8.5.0 and immediately after that all dashboards work again :smiley:

1 Like