Group Alarms Fibaro FGSD002

There’s no need to exclude the device.

I’d suggest to stop the binding, delete the XML for this node (in the {userdata}/zwave folder) and then restart the binding. Set polling to 30 seconds and let’s see what it shows.

Logfile has 7 MB how can i upload?
(is limited to 1MB)

File uploaded

Unfortunately the file has no zwave debug logging in it (lots of other debug though which is why the file is so big). To enable debug logging, use the following command.

log:set debug org.openhab.binding.zwave

You might want to see if you can disable some of the other logging otherwise the file might get quite large.

For reference -:

But the logging is than stored in /var/log/openhab2/openhab.log ?


I’m wondering, as a switched log:set Debug…

Sorry - I don’t know what you mean?

I started karraf shell and switched to:
log:set Debug

I think, that should have turned on Debugging also for zwave…

If I turn on logging like that:
log:set debug org.openhab.binding.zwave

How do I switch back to warning?
Is it:
log:set warn org.openhab.binding.zwave

No - I don’t think so.

This will set the logging for zwave to warn - we need to have debug for the test, but you can switch this after if you want.

Here we go :wink:
openhab.log.xml (116.4 KB)

It is polling the Device, also it shouldn’t:
2017-10-27 20:08:31.627 [DEBUG] [ding.zwave.handler.ZWaveThingHandler] - NODE 16: Polling intialised at 60 seconds - start in 60000 milliseconds.
2017-10-27 20:08:59.101 [ERROR] [inding.edimax.internal.EdimaxBinding] - Device with MAC: 74DA384A6AE5 not found/discovered.
2017-10-27 20:09:29.153 [ERROR] [inding.edimax.internal.EdimaxBinding] - Device with MAC: 74DA384A6AE5 not found/discovered.
2017-10-27 20:09:31.630 [DEBUG] [ding.zwave.handler.ZWaveThingHandler] - NODE 16: Polling…
2017-10-27 20:09:31.631 [DEBUG] [ding.zwave.handler.ZWaveThingHandler] - NODE 16: Polling zwave:device:020e4758:node16:switch_binary
2017-10-27 20:09:31.632 [DEBUG] [converter.ZWaveBinarySwitchConverter] - NODE 16: Generating poll message for SWITCH_BINARY, endpoint 0
2017-10-27 20:09:31.633 [DEBUG] [dclass.ZWaveBinarySwitchCommandClass] - NODE 16: Creating new message for application command SWITCH_BINARY_GET
2017-10-27 20:09:31.635 [DEBUG] [ding.zwave.handler.ZWaveThingHandler] - NODE 16: Polling zwave:device:020e4758:node16:sensor_binary
2017-10-27 20:09:31.636 [DEBUG] [converter.ZWaveBinarySensorConverter] - NODE 16: Generating poll message for SENSOR_BINARY, endpoint 0
2017-10-27 20:09:31.637 [DEBUG] [dclass.ZWaveBinarySensorCommandClass] - NODE 16: Creating new message for application command SENSOR_BINARY_GET
2017-10-27 20:09:31.638 [DEBUG] [ding.zwave.handler.ZWaveThingHandler] - NODE 16: Polling zwave:device:020e4758:node16:alarm_general
2017-10-27 20:09:31.639 [DEBUG] [ding.zwave.handler.ZWaveThingHandler] - NODE 16: Polling zwave:device:020e4758:node16:battery-level
2017-10-27 20:09:31.640 [DEBUG] [rnal.converter.ZWaveBatteryConverter] - NODE 16: Generating poll message for BATTERY endpoint 0
2017-10-27 20:09:31.641 [DEBUG] [ommandclass.ZWaveBatteryCommandClass] - NODE 16: Creating new message for application command BATTERY_GET
2017-10-27 20:09:31.643 [DEBUG] [ocol.ZWaveController$ZWaveSendThread] - Took message from queue for sending. Queue length = 0

… but the node isn’t answering:
2017-10-27 20:09:54.182 [DEBUG] [l.serialmessage.SendDataMessageClass] - NODE 16: SendData Request. CallBack ID = 7, Status = Transmission complete, no ACK received(1)
2017-10-27 20:09:54.183 [DEBUG] [l.serialmessage.SendDataMessageClass] - NODE 16: Node is DEAD. Dropping message.

Thanks. What I need to see is the initialisation. As above -:

Well, that’s the big question. If the device sends the wrong information, then the binding may not be able to tell this. The binding won’t poll devices that are battery operated until they wake up, so this device must be doing something abnormal otherwise the binding would not work with ANY battery devices, and it does.

OK, how do I stop and start the zwave binding?
Is the xml file than created again after restarting the binding?


OK, I stopped Binding, deleted xml File , started Binding… xml file was created again.
Here’s the Log:

It looks like the issue is that the device doesn’t support the wakeup class, so the binding doesn’t / can’t queue the frames, so it just sends them. In reality this isn’t an issue - the device shows offline, but it will still work fine if it sends a message.

I don’t think this issue will occur with the development version of the binding so you might want to try that.

Thanks, How can I switch to development version?

Thanks, How can I switch to development version?

See this thread -:

I know this is a long thread but the top 6 or so messages provides information on installing.


I fixed it!!! :wink:
That’s what I did:

  1. stopped ZWave Binding
  2. Deleted xml File for Device
  3. Set Device to Factory Reset
  4. started Zwave Binding
  5. Included Device againg (it got a new node ID)
  6. Created Thing and Items
  7. Everything works now, the Device doesn’t lose connection any longer.

Thanks for your support



1 Like