Growatt Binding

This is to announce that I have started work on a “proper” binding for Growatt inverters.

I am aware of the thread here which explains how to import Growatt inverter data via MQTT.

However, the purpose of this new binding is to integrate Growatt inverters in the “normal” way as a standard thing with standard channels without having to fiddle around with MQTT stuff.

You can read about the binding and explore the code via this link.

If anyone is interested in helping the development by volunteering as a ‘guinea pig’ please let me know.


Don’t wanna brake you just a hint upfront. Almost any inverter can do modbus and unless you have specific needs such as to implement some extra control logic it is often sufficient to parametrize a modbus binding thing and set of items.
That’s already a huge improvement over MQTT as we don’t have to fiddle with synchronizing config in two places (OH and MQTT broker) it’s only OH config then.

Understood. But I think there are a few reasons why I will proceed anyway…

  • It means buying a new piece of modbus to ethernet hardware.
  • The ModBus registers used by Growatt are not documented.
  • I already pretty much finished the binding coding :wink:

do you already have something to share?

1 Like

I have had this binding operating for several months now. But unfortunately reviewers seem not to have any time to review it. So I am thinking of publishing it instead on Marketplace. WDYT?

of course, please do. Thought you had already.

1 Like

Done :slight_smile: see here…

I am using an inverter in an VPN connected subnet (192.168.177.xx).
The server (Synology NAS with Grott + Openhab) is located in a different subnet (192.168.178.xx)
Will this method (Grott Service on Synology NAS (in Docker?)) work as specified?

I guess it depends on whether there is routing between your two sub nets. The connection is based on IP addresses so if the subnet can route the respective IP addresses it should work.

1 Like

Hi Andrew

Thanks for making this binding
I have a questions:

  • how do you see the “bridge thing” and “inverter thing” or add the bridge thing?
    ->under “Add manually” it states “No thing types can be added with this binding.”


1 Like

You create the bridge thing manually. Once the bridge thing is created, it will show status unknown. But once the grott application sends data to it, two things will happen 1) the bridge status will change to online, and 2) an inverter thing coresponding to the received data will appear in the Inbox (where you can then instantiate it).

Thanks for the answer.
How do you create it manually?

Umm. I think via the + button at bottom right corner of Main UI things

I tried that, its not working.
Iam on version 4.0.4

What do you mean ‘its not working’?




when i do this the menu looks like this

no bridge or inverter thing to add.
Have uninstalled the binding and installed it again, no change
Could it be that something is wrong with the binding installation file from marketplace?

I have no idea.

I agree to Sebastian, there is no option to add things to the binding installed from marketplace.
If I am using the linked .jar file openhab is not recognizing the binding.

“The marketplace bundle was successfully installed but doesn’t start: Could not resolve module: org.openhab.binding.growatt [323]
Unresolved requirement: Import-Package: javax.measure; version=”[2.2.0,3.0.0)“”

The solution might be here (common issue with 4.1 versus 4.0.x)

You probably need to use a current milestone build.