HABMIN OH2.4 and ZWAVE "no entry" symbol

Tags: #<Tag:0x00007f616d13e428> #<Tag:0x00007f616d13e360> #<Tag:0x00007f616d13e1a8>

I have been using IOBROKER for almost a year now, and it’s pretty good, especially the UI designer, but its zwave handling (admin) is not great and the support forums are German (which requires google translate for me) and there are not too many adapters.

I’m not sure what I am doing wrong, I have experimented for a week to correct the issue, and it was an issue I had a couple of years ago when trialling OH2. I can’t seem to get past it, but obviously it works for other people.

There are a few (seemingly related) issues, but the main one is the Wave network display; if I try to use the “zwave network viewer”->Device Tools menu, the cursor changes to a “no entry” and nothing is clickable, and nothing in my mini zwave network appears. I have checked the zwave nodes and they show neighbours and seem to work when controlled from the paperui.

Similarly, the “Dashboard-Edit Widget Properties” window also gives me a “no entry” for the “Title”, “Widget Border Type” and “Dashboard to link when clicked” fields on the “general Properties” screen. I can, however, change values on the “Gauge Properties” screen - I’m just trying a simple test to display a value from one of my items (which has a numerical value).

Some posts led me to try various java option settings on my Mac, but since I have the exact same issues on my windows pc, this seems less likely to be the cause.

I would like to move HA systems, but unless I can get past the above issues, OH2 is not useable for me.

Lastly, the most confusing of all is when I open Habmin, the screen has a page that says “a graphical user interface for openHAB” Version 2.0.0, 2018-12-17, and a download link.
Isn’t this HABmin already? why the link, why does the zwave list ofmy items appear in black on white, where many of the sample images of HABmin2 show the zwavef nodes with grey on black, and status indicators for battery and item type etc. I don’t see this on my HABmin.

I followed the install-how-tos and had no luck, trawled the forums and tried various fixes, and still no luck, so in desperation I’m sending a NOOB post.

I hope someone has the solution for this(these) issues and can help out, otherwise I will have to stick with I-broker and google-translate.

SYstem(s):
Odroid using hard kernel supplied Ubuntu, with apt updates applied
OH2 installed and addins from the paper UI applied, including Habmin and zwave
Client accèss is a Mac running Mojave, and safari/chrome/firefox, also tried a windows 10 VM

I repeated the install process on a VM running ubuntu, hosted on a windows 10 pc and still the same issues occur.

Have you got a zwave adaptor or gateway?

It’s just telling you what it is. The link takes you to the Github entry for Habmin, which is perhaps not what you are expecting to see, but Habmin is aimed at system administrator not “end user”.

Thanks for the reply, Yes I have a controller - aeotec zstick on the openab system - I have a zway controller (UZB) on my actual Iobroker system which has the house (non test) nodes in it - but until /if I can get OH working properly then won’t be moving the controller USB.

Yes,I am familiar with GitHub, the confusion is the current Habmin screen does not say what version it is, and it does not look anything like the habmin2 screenshots I’ve seen (at least for the zwave list). To me it is saying, you have an old version of Habmin - go here to download the newest version.

My OH 2.4 Habmin looks like
Untitled
I guess it’s easy enough to make an enhancement request to have the download button removed if it’s a worry.

Sounds like your temporary zwave isn’t working right. I don’t know anything about zwave, like how much of a working network you need to utilize the viewer tool.

It’s probably a good idea to show us your zwave things (assuming you are using the 2.x binding)

Included below are the zwave Things and the Habpanel view. The zwave devices seem to be working okay they are networked together as listed in their respective properties. They are controllable and report to the main controller.

The habpanel is blank, and the options button is not selectable.


Might be relevant

Else change the post tag to include zwave to attract more experience

Thanks for the tip, I believe I have added the zwave tag now.

I loaded the HABpanel page on Firefox with debug console - the function with a return statement in the first line probably isn’t a good sign for this function doing anything useful.

See also