HABPanel does not show value in dummy widget if format given for group aggregation

I’m trying to specify a format in the HAPPanel standard dummy widget, but as soon as I specify a format, the widget does not show a value.

The working widget showing a value:
image

with it’s settings:
image

And here the widget with the format specified as %.3f and it’s showing no value (I’m using the same formatting to show all individual cell voltages and this works). It’s just showing the Name and it has nothing to do with the size and also I’ve tried different float formatting without success.
image
image

The item is defined like this:

Group:Number:ElectricPotential:MAX gSolarBatteryOverallHighestCellDelta "Battery Overall Highest Cell Delta" <sun> (gSolar)

Each of the 12 individual items are defined like this:

Number:ElectricPotential SASolarBattery1HighestCellDelta "SA Solar Battery 1 Highest Cell Delta Voltage" <sun> (gSolar,gSolarBatteryOverallHighestCellDelta)
Number:ElectricPotential SASolarBattery2HighestCellDelta "SA Solar Battery 2 Highest Cell Delta Voltage" <sun> (gSolar,gSolarBatteryOverallHighestCellDelta)
...
Number:ElectricPotential SASolarBattery12HighestCellDelta "SA Solar Battery 12 Highest Cell Delta Voltage" <sun> (gSolar,gSolarBatteryOverallHighestCellDelta)

The values of the individual items are set via rules (I’ve tried postUpate() and sendCommand() for the individual items and both are working, but not the MAX aggregation).

I’ve a similar group for calculation of an AVG aggregation out of separate items and in this case, it’s working.

What I’m doing wrong?

Edit:
The difference between my group aggregation which works with formatting in HABPanel get’s it’s values from items with real channels (via MQTT).
The group aggregation which could not be formated in HABPanel get’s it’s values form virtual items which are set by rules (tried postUpdate() and sendMessage()).

Maybe it has something to do with that?

If I use the string formatter

%.5s V

I’ll get the correct result:
image

This is ok for my situation where the number always starts with “0.” but this is just luck. I want to understand, why the float formatting is not working for this group aggregation but for others.
Any explenations?