Habpanel home screen app unresposive

I have installed the Fullscreen-App “Vollbild-Clock” as a Screensaver:


Habpanel let you activate this App with an openHAB-Item and Rule. In addition I have placed a motion sensor near to the tablet that gives me the possibility to wake up HabPanel (= close Vollbild-Clock). I’m quite happy to see date/time and as soon as I’m in front of the Tablet HabPanel does automatically open :slight_smile:

I could also help you with the rule if you are interested how to implement.

Yannick -

I was experiencing similar ‘hangs’ of habpanel and followed your guidance here. In my normal situation, I run habpanel on an old iPad in Safari. For debugging purposes I am currently running habpanel in Chrome on a Mac with Developer tools enabled.

In my situation, I have Sonos album-art displaying (correctly) on my habpanel. As long as the albumart is showing, I keep getting the following error every refresh of the albumart (5sec):

vendor.js:119 TypeError: Cannot read property ‘indexOf’ of undefined
at image.widget.js:70
at n (vendor.js:108)
at m.$eval (vendor.js:147)
at m.$digest (vendor.js:144)
at m.$apply (vendor.js:147)
at vendor.js:109

Once I remove the albumart from the panel, the error messages stop appearing. This may be the cause for my hangs every few hours. I am now running a test to see if habpanel still freezes and will report that back later.

[EDIT - 24 hours later: Habpanel is still running. No more errors in the developer tools logging and no more hangs after I removed the Sonos albumart from the panel]

[EDIT2 - 48 hours later: Habpanel stopped responding again :frowning: No clue why. No error messages in developer tools. I can click the little refresh icon on the habpanel top and that actually refreshes the page, but only once. I need to go back to my (iPad) home screen and restart safari for it to start refreshing again…]

Any idea’s what’s causing this error message?

Many thanks,

Any more updates on this? I have an android mini pc with a touchscreen monitor attached. It does not go to sleep, but after some times the ui become unresponsive. Tried different browser, tried the Habviewer app, tried enabling HW Acceleration, tried another mini pc, same problem. For what i can see, this problem doesn’t seems to exist on windows.

This is my configuration, i don’t see any “cpu intensive” object:

Has anyone fixed this? I get the same issues. You cant just put a tablet on the wall and have it be responsive 24/7, you always have to restart the app to get it to respond again


Same for me. What can i provide to help with this issue?