Habpanel with API Authentification error 401

Hi together,

i just set up openhabian on my Raspberry Pi 4 2GB.

If I open ther HABpanel, it displays in the bottom left “connection lost, trying to reconnect”. In the developer mode, chrome tells me about error 401 while getting data from https://openhabIP:8443/rest/items
using http produces the same error.

Is it possible, to add an API key to the HABpanel so i don’t have to rurn off the API authentification?

Thanks in advance


Just need to log into the main UI on the device first. It should remember your logged in and not ask again unless you clear the cache in the browser.


Best, Jay

Thanks Jay,
i logged in but it still does not load the content of my dashboard.

Without the API authentification it shows my demo clock

with authentification enabled it only shows the dashboards name and the error.

Regards, Tim

Are you using the HabPanelFilter special JAR to filter items from the REST API Item call?

Also, can you see the number of items in your Main UI? If not, then there is a bigger problem than HabPanel.


Best, Jay

I haven’t set up filters.

I can see the count of the Items in my main configuration window

Regards, Tim

I’m at a loss then, I had similar issues as you when I cut over to 3.x and it was because of the last 2 scenarios I asked about.

Sorry, Jay

Does someone have any idea?

When I open https://myip:myport/rest it shows me a json with the further links. If i open one of the links, (eg. /rest/items) it shows me the following json.

    "error": {
        "message": "Authentication required",
        "http-code": 401

I also tried both http and https and different browsers.

It alsop did not work as I tried http://myusername:mypasswort@myip:myport/rest/items

This topic was automatically closed 41 days after the last reply. New replies are no longer allowed.