HABPanelViewer

android
habpanel
Tags: #<Tag:0x00007f6cea3cbbb8> #<Tag:0x00007f6cea3cb988>

(Volker Bier) #201

I did not really think about that. I have now changed the SCREEN_ON command to set brightness back to original value in case it is dimmed.


(Magnus) #202

In have a similar problem. My Lenovo tablet do not start remotly if I turn it of with “allow_screen_off” and then try to start it with “keep_screen_on”. I have to turn it on with the switch. And I also have to send/update the item with “keep_screen_on” after I manually started the tablet to prevent it to turn of the screen.
I did work as expected with the old version of HabPanelViewer so it shuld not be any problem with the tablet.


(Volker Bier) #203

I made a minor change to the code that wakes up the tablet, but that should not make a difference according to the android api docs. Can you please update to the newest version (I just pushed an update) and reproduce the problem? Afterwards open the Command Log from the menu and see if the commands have been received/processed by HabPanelViewer?


(AH) #204

This is great, thank you.

I know I can set a default panel, but is there a way to set a default dashboard within that panel?


(Michael Ritterbusch) #205

The “Start Panel” option is what set which dashboard to open at startup. This is the actual panel name in the config (CASE sensitive, you can get by the last part of the url when you are on that dashboard.

image

image

Also, you can set the default panel in the PaperUI under Configuration->Services->UI->HABPanel


(AH) #206

Ah, thanks Michael. I can see where my confusion came from. I’ve messed something up (very new to this).

You wouldn’t happen to know where I can change that name - to change ‘dashboard’ to Lounge to get it back in sync. Or is it too late now?
I also should have known better that it was case sensitive on another test I did.

I’m probably the only one, and maybe it’s because a lot is changing, but I thought there were panel configurations e.g.

and that the Lounge, Upstairs etc in my example were called Dashboards - the documentation would seem to support that. https://docs.openhab.org/addons/uis/habpanel/readme.html

That said, you’re entirely rightand for anyone else coming to this, entering ‘Dashboard’ in the start Panel option opens up the Lounge one correctly.

Thanks for coming back to me on that - appreciated.


(Michael Ritterbusch) #207

I ran into that when 1st starting with Habpanel as well. I created my 1st dashboard as “TestPanel” which eventually became my “Main Menu”… You can’t rename the dashboard currently***. The easy way is to create a new dashboard named properly (ie. “MainMenu” in my case) and then just copy all your widgets from the existing to the new one. (will have to arrange them again, but is a very easy/quick process)

***afaik. however, all the dashboard/panel config is all in a .json file which you could edit. However, 2 main caveats:

  1. not for novice
  2. OH service needs to be shutdown when editing .json files. OH reads on startup and overwrites as changes are made. It doesn’t re-read any of them after startup.

(Yannick Schaus) #208

Changing the id of a dashboard afterwards is not supported currently, but you can hit the “Edit the local panel configuration (experts only)” link in the screenshot above.
It will show you the JSON object and you’ll be able to find the affected id and change it - be careful though!


(Valentino) #209

Hi to everybody
I download and test HABPanelViewer and it is good.
I’d like to know if is possible to start an app from the status of an item in openHAB?
it will be very useful for example to switch from HABPanel and other app
cheers
valentino


(-) #210

@vbier - thanks for a very useful app! One thing I have been struggling with on the new test build is consistently getting commands to reach the tablet (Kindle Fire 7"). I have managed to get commands to get through a few times (and the command log shows these), but then for some unknown reason, commands stop going through. I have tried rediscovering the server etc, but still nothing. However, the auto-complete in the Command Item settings dialogue correctly shows the item.

Can you suggest if there is anything else I can/should be doing?

UPDATE: One thing I noticed is that the panel is showing “not connected” in the menu, even though the dashboard appears to be showing fine (and responding to key presses). Doing a fresh discovery then re-finds the same server, and this time shows connected correctly for a period of time. Again, a short time later, the menu shows “not connected” and commands stop getting through.


(Volker Bier) #211

There are two connections involved: one made by the browser and one made by the app in order to get item state updates from openHAB. The second one is also used to show the connected state in the menu. I use a library for making the connection called com.tylerjroach:eventsource. This should, in theory, try to reconnect as soon as the connection is lost.

Can you grab the log and send me the interesting part?


(Volker Bier) #212

I have just pushed an update that has a new command START_APP. It has one argument, which is the package name of the app. You can look that up in Settings->App->App of your choice. The package name is shown below the version, it is e.g. com.android.chrome for Chrome.

So with command

START_APP com.android.chrome

you can now start Chrome.


(-) #213

I’ve attached a logcat snapshot covering a period of from rediscovering the server to getting to a disconnected state - the whole process is only a couple of minutes. I hope this covers it but do let me know if you need anything further. Thanks again.

EDIT: Connection seems to get lost when the device goes to standby. I have tried using both with and without SSL (as with SSL it initially gave some warnings, which I told it to ignore), but the problem persists.

The log file below should cover a period where I have changed from https back down to http (and the connection is lost after standby)


(Volker Bier) #214

This looks like the device is enforcing some kind of power saving mechanism. Does the Fire tablet have settings that allow to specify whether WIFI should stay enabled when the screen is turned off?

We already had some other people in this thread with Fire Tablets. Does anybody else have an idea?


(-) #215

Nothing obvious in the usual places. I’ve tried a setting in developer options that allows constant scanning for wifi roaming but that didn’t help with the problem.

One odd thing that I noticed this time round was that when I came out of standby, HABPanelViewer was still showing as connected. However, no commands were getting through (and command log was showing empty). A few minutes later - with the device having remained continuously on - the HABPanelViewer showed its not connected status. I think the log attached captured this period.

logcat3.7z.xml (97.6 KB)


(Volker Bier) #216

I have added some more logging. Can you please reproduce and update the log?

edit: please open an issue in github and we can continue there.


(James Hiscott) #217

@vbier I have a few problems. Using an Amazon fire 7.

  1. if i set the motion setting to updated openhab when it can see motion it only seems to work when i first open the app, I get a very quick message int eh openhab logs to say “set to open” then “set to closed”. If i turn on the preview window i can see it detecting the motion, the word “motion” shows up at the top of the screen but the openhab item is never set. I had this problem in the play store version and the new apk you uploaded.

  2. if i setup the new command bits and send the SCREEN_ON command once the screen is off it will turn back on some times, but other times it causes the tablet to reboot or the app to hang.

Anything i can get for you to aid with investigation?


(Volker Bier) #218
  1. If the contact is set to closed that means motion is detected. After a period without motion the contact is then set to open again (which means no motion).
  2. Buy me a fire 7 :slight_smile: or grab a log and send it to me.

edit: please open an issue in github and we can continue there.


(-) #219

Done - https://github.com/vbier/habpanelviewer/issues/10.


(Valentino) #220

thanks for the reply

I’m new here, where i can download the update version .apk of the app for test?

thanks
Valentino