HAI omnilink binding for Openhab 2.0

openhab2
omnilink
binding
Tags: #<Tag:0x00007f014bd14d88> #<Tag:0x00007f014bd14b30> #<Tag:0x00007f014bd14950>

(Gabe Klingensmith) #1

I have an HAI/Leviton Omni LTE panel. A few months ago I started working on getting Openhab 1.x up and running on a Raspberry Pi and have had some pretty good success. I started a new installation last night of Openhab2 on Ubuntu and I am trying to get the omnilink binding installed. I don’t see it in the list of addons from PaperUI. Is it included in the list of approved/official bindings for Openhab2. If not, will it be in the near future? I had some issues with it for the 1.x build that I am hoping to overcome in 2.x. Any comments are welcome, and thanks in advance for your help.


(Rich Koshak) #2

You can install and run “unofficial” 1.9 version binding by following the information here:

http://docs.openhab.org/addons/bindings.html#further-1x-bindings

If you get it to work file an issue on the openhab2-addons github repo or post a new thread here telling us it works and it will get added to the list in PaperUI.

However, if your problems are with this particular binding realize that you will be running the same code, just on a new core platform.


(Gabe Klingensmith) #3

Thanks, I will give it a shot. My problems weren’t with getting it to install and work, I was issues with arming and disarming my system. I could get Openhab to arm the system for day, but that was about it. It didn’t seem to recognize the code it was sending for “night”. I used some examples from another post that DigitalDan had written. I will try to get it working on 2.0 and see what I see. Thanks.


(Gabe Klingensmith) #4

The 1.9 binding seems to be working as it did under openhab 1.x

However, I still only get the “disarm” and “arm away” to work. Does anyone have the different arming buttons working correctly? Thanks in advance for the help.


(Gabe Klingensmith) #5

Is anyone still working on the omnilink binding?


(Nathan Wagner) #6

Is this binding going to be added to 2.0 PaperUI since it’s behaving?


(Rich Cole) #7

I have just started to look at this binding…


(D. D. Walker) #8

Newbie questions – Am totally new to OpenHAB 2.0 and have just installed (Mac OS X 10.12.6).

I would like to install HAI OmniLink binding to talk to my OMNIPro II as well as the SimpleBinary binding (for another activity).

Neither is listed in Paper UI …

Where can I find each of these?
What do I need and how do I install.

TIA,
–DDW


(Craig) #9

install the marketplace plugin first, it allows you to download bindings (i.e. Omnilink) which are available on the eclipse marketplace. It can be found under the misc tab of bindings I believe.


(Guy Wenzel) #10

Craig,

Will this binding work under openhabian?

Thanks

Guy


(Craig) #11

Ya it should work. Try adding the marketplace add-on, then the omnilink binding should show up.


(Guy Wenzel) #12

I got it working once I realized to configured the controller in the PaperUI versus the cfg file. All my units appeared.

Thank you!
Guy


(Guy Wenzel) #13

Again thanks for your efforts on the binding.

Guy


(Craig) #14

no problem. there was a lot of help from @boc-tothefuture and @digitaldan

Good to hear it is getting used by more people, let me know of any issues you may find.


(Joe Morris) #15

Hi Craig,

I too am trying to use the Omnilink under 2.0

It locates all of my devices but it then stays in an Initializing state.

Hence I am unable to get any of the devices to work.

I am new to HAB so I might be missing a step.

Any help would be greatly appreciated.

Joe


(Wendell M) #16

I’m setting up openHAB 2.1 on a new MacOS system, and I have the OmniLink binding (from the Marketplace) loaded. I added the keys for my OmniPro II and did an Inbox | OmniLink Binding | Search in PaperUI, and it found a bunch of my OmniPro devices (Thermostats, Security Zones, Buttons, Flags), but none of my Units (which are Leviton Vizia RF+ devices). I’ve got a ton of Units in my system, and not a single one is showing up in the list of Things. Do I need to add or select a Thing (similar to how I had to select an Omni Area before I could see the Channels within it in the Configuration | Things list) before it will display all of my Units?

Thanks ahead of time for any help. I’m excited to get openHAB 2 up and running now that there’s an official OmniPro binding!


(Chris) #17

I am having the exact same issue. I used an OpenHabian image, went to the marketplace and got the OmniLink binding, setup a controller successfully and then was able to get all my Things except for my units. If I try to add the units manually I get a 500 error after I enter a Unit number. I think I’ve probably missed a setup step. Any advice is appreciated!

Thanks.

Chris


(Wendell M) #18

With lots of help from others I’ve got a working system now. The problem is that the OH2 version of OmniLink doesn’t support a plain “Unit” like version 1.x did. You have to use UPB units for it to work, and I found it best to set up static maps in case something goes haywire with the OH2 database (better than having to start from scratch each time). You also must use very specific syntax in the .things and .items files, and certain parts weren’t obvious to me from the documentation. It’s a lot more convoluted to set up than it was under OH1. Here are some sample lines from my .things and .items files that will get you going:

.items file (placed in openhab/conf/items folder):

Dimmer Light_L1_Kitchen_Ceiling	        "Kitchen Ceiling [%d]"			(L1_Kitchen)		["Lighting"]	{channel="omnilink:upb:home:Light_L1_Kitchen_Ceiling:level"}
Switch Light_L1_Kitchen_Counter			"Kitchen Counter [%s]"			(L1_Kitchen_Accent)	["Lighting"]	{channel="omnilink:upb:home:Light_L1_Kitchen_Counter:level"}	

In the above lines, note that you need to use %s if it’s a switch and %d if it’s a dimmer (or at least that’s the only way I could find to make them work correctly). Also, the text in the ( ) is the group name you assign, and the text in the [ ] is a tag you need if you’re going to use HomeKit in OH2. FYI… I’m still having problems with HomeKit not staying connected to my iOS devices, so while OH2 can control my lights now, I still don’t have reliable control from Siri. You can leave out the entire [xxx] part if you’re not using a binding that needs tags.

.things file (placed in openhab/conf/things folder):

Bridge omnilink:controller:home [ipAddress="192.168.1.100", port=4369, key1="1st half of OmniPro key", key2="2nd half of OmniPro key"]
    
    Thing upb Light_L1_Kitchen_Ceiling			"Kitchen Ceiling"		@	"Kitchen"		[number=18]
    Thing upb Light_L1_Kitchen_Counter			"Kitchen Counter"		@	"Kitchen"		[number=21]

In the above lines, you need to use the correct IP address for your OmniPro system, and also your OmniPro key values. The number=xx refers to the device number you see in PC Access for that unit.

Hopefully this is enough to get you going. Let me know.


(Andrew Bush) #19

Is there a link to the latest documentation available.
Trying to replicate my Omnilink set up from V1 in V2 etc

PS - Thank you very much for picking this up again and porting it to V2. Much appreciated.


(MARCEL) #20

I just installed the Omnilink binding from Eclipse IoT Market. However, I cannot find clear instructions on how configure my port, keys, and host data and populate my things. I attempted to follow some old github instructions dated Oct 28, 2014, quoted below.

“Copy the binding jar (org.openhab.omnilink*.jar) to the addons directory and add the following to your openhab.cfg…
omnilink:port=4369
omnilink:host=panel.yourdomain.com
omnilink:key1=00:AA:BB:CC:DD:EE:FF:11
omnilink:key2=00:AA:BB:CC:DD:EE:FF:11
omnilink:generateItems=true”

I added my specific omnilink data to /etc/openhab2/services/addons.cfg and did a new search on PaperUI, i.e. Inbox > Omnilink Binding > Search. But my things were not found.

Could someone point me to instructions to configure my Omni panel? For reference, I have a PI2, running openhabian, and an Omni IIe Thanks.

Marcel