Haozee Zwave Plus Water Leak Sensor - No notifications?

Tags: #<Tag:0x00007f5ca34eb130>

Hello all.

I am running the latest Openhabian stable build (as of today) on a Raspi 3.
Everything works well, EXCEPT for this Haozee Flood Sensor I picked up on amazon a while back.

I’ve got it paired, and it’s correctly recognized as a flood sensor, but for whatever reason, I am unable to get it to provide my openhab setup with any updates when water is detected!

Here are some details of the device itself:

dbReference	493
defaultAssociations	1
manufacturerId	0258
manufacturerRef	0003:0085,0003:1085,0003:2085
modelId	Flood sensor
vendor	Shenzhen Neo Electronics Co., Ltd
zwave_beaming	true
zwave_class_basic	BASIC_TYPE_ROUTING_SLAVE
zwave_class_generic	GENERIC_TYPE_SENSOR_NOTIFICATION
zwave_class_specific	SPECIFIC_TYPE_NOTIFICATION_SENSOR
zwave_deviceid	133
zwave_devicetype	3
zwave_frequent	false
zwave_listening	false
zwave_manufacturer	600
zwave_neighbours	
zwave_nodeid	6
zwave_plus_devicetype	NODE_TYPE_ZWAVEPLUS_NODE
zwave_plus_roletype	ROLE_TYPE_SLAVE_SLEEPING_REPORTING
zwave_routing	true
zwave_secure	false
zwave_version	0.0

the channels I have items for are:
Flood Alarm
Battery Level

The flood alarm is listed as a switch type.

Battery Level as a number.

Neither reports anything back to Openhab.

Under association groups, I set the Lifeline (group 1) to controller. I tried even setting 2 (basic set), 3 (notification report v4) and 4 (sensor_binary report_v2) to Controller as well to see if it was sending something another way, but no dice.

My rule is as follows:

rule "Basement Leak Detector Leaking"
when
        Item BasementLeakDetector_FloodAlarm received update ON
then
        logInfo("notifications", "Basement Leak Detector - status changed")
        sendNotification("myemail@myemail.com", "Water detected in basement!")
end

rule "Basement Leak Detector Dry"
when
        Item BasementLeakDetector_FloodAlarm received update OFF
then
        logInfo("notifications", "Basement Leak Detector - status changed")
        sendNotification("myemail@myemail.com", "Basement is dry again!")
end

The email of course was sanitized for my protection.
For the hell of it I tried a simple if item changed rule, to no avail.
Nothing reports in openhab for events or in the openhab log either that the device is sending updates to the controller. The device correctly detects water as it beeps as expected, but from there, nothing.

Any ideas what I may be doing wrong? Do I need to change a configuration of the device or items somewhere?

Welcome!

That is a battery operated device. Many times they need to be woken up many times when adding to openHAB to get fully discovered buy the binding.

Have you set up any Items mapped to those Thing channels? OpenHAB manages Items, not Things.

Welcome.

There is no need to do anything with Lifeline. The binding figures it out now.

With other z-wave flood sensor examples on the Openhab forum I’ve seen that folks need to set the lifelife to the controller, so tried that. With nothing set it still sent no updates.

The device has been woken up a dozen times, removed, readded, etc.

It’s defintely been fully discovered by the binding, as Openhab found it, figured out everything about it, etc.

As for items, yes, BasementLeakDetector_FloodAlarm is the flood channel. It’s set as a switch type and for water (openhab set those types).

I had a dome leak sensor before that had similar setup and worked ok.

Not sure what else to do. Seems that in the log files it’s not even getting any updates?

The zwave binding documentation has a section on how to turn on debug logging when things do not go as planned.
That may provide more clues.

I think I’m gonna give up on it. Reading some more recent reviews on it stating it won’t work right with even smart things and I think one person said they could not get it working with openhab.

I have two of those and they are working fine.
Include them properly and wake them several times:
https://www.cd-jackson.com/index.php/zwave/zwave-device-database/zwave-device-list/devicesummary/493

1 Like

Dang, I am very glad you posted!
So, the one thing I hadn’t done apparently is woke it up a number of times. Probably had to about 7-8 times in a row before it decided to properly work. Before that, the association groups, etc. was fine but…why that had to be done?!?

I have a dome sensor on order for leaks…will need two anyways due to the things I want to monitor so this works beautifully. Thank you!

Battery operated devices sometimes are only awake for a short period of time. During first initialization that time is too short for a complete initialization, therefore you have to wake them several times.

1 Like

Make sure you are reading this:

1 Like