Has anyone gotten RaZberry working with OpenHAB 2?

openhab2
zwave
binding
Tags: #<Tag:0x00007f15d5cfda90> #<Tag:0x00007f15d5cfd950> #<Tag:0x00007f15d5cfd7c0>

(Ash Raj) #1

If you have, can you please post the exact steps you followed? I’ve tried every recommendation in this forum, but nothing has worked. I still have the same error: Port /dev/ttyAMA0 does not exist. I’ve tried clean installs of Raspbian Jessie on my RPi 2 and 3 multiple times.


(Igor) #2

Here you have all steps:

http://docs.openhab.org/installation/apt.html

And

http://docs.openhab.org/installation/rasppi.html


(Martin Eskildsen) #3

I have the UZB stick on the Rasberry Pi (I believe that is a similar controller?)

Are you sure it is the correct port you are referring?
As far as I remember, I had to add the user to a dialout group. You could offcourse run as root (while testing).


(Rob B) #4

I have a Razberry working ok on my Raspi 2 so happy to join the discussion. Interesting comment about running as root. I am still doing this as routine. Maybe I need to do what’s needed so i can run as normal user.
ls -la /dev/ttyAMA0
crw-rw—T 1 root dialout 204, 64 Jul 23 08:35 /dev/ttyAMA0


(Ash Raj) #5

I am running OpenHAB as root, and there are many posts on this forum saying to use /dev/ttyAMA0 for RaZberry. (USB sticks like yours use a different port.)


(Rob B) #6

@Ash
What does ls -la /dev/tty*
give you?


(Felix Lo) #7

I have openhab2 running on raspberry pi 2 till latest and as normal user instead of root.


(Frode Heiland) #8

OpenHAB 2 running with Razberry2. Working great so far.


( ) #9

That’s great. Can you tell @Ash and others how you did it?


(Frode Heiland) #10

To get Razberry2 to work I had to:

In /usr/share/openhab2/runtime/karaf/bin/setenv i had to add:
-Dgnu.io.rxtx.SerialPorts=/dev/ttyAMA0:/dev/ttyUSB0"

In /boot/config.txt I had to add:
enable_uart=1

In /boot/cmdline.txt had to change the line to:
dwc_otg.lpm_enable=0 console=tty1 elevator=deadline net.ifnames=0 root=/dev/mmcblk0p2 rootfstype=ext4 rootwait

Thanks to ThomDietrich for putting me on the right track.


(BlizzWave) #11

To note, on the Raspberry Pi 3 /dev/ttyAMA0 is used by the bluetooth.
Razberry2 board can be found on /dev/ttyS0

To get Razberry2 to work with Raspberry Pi 3:

sudo nano /usr/share/openhab2/runtime/karaf/bin/setenv

-Dgnu.io.rxtx.SerialPorts=/dev/ttyS0:/dev/ttyUSB0"

sudo nano /boot/config.txt
Add to the end:

enable_uart=1

sudo nano /boot/cmdline.txt
Remove everything and add this:

dwc_otg.lpm_enable=0 console=tty1 elevator=deadline net.ifnames=0 root=/dev/mmcblk0p2 rootfstype=ext4 rootwait

Then run these commands:



sudo usermod -a -G dialout openhab
sudo usermod -a -G dialout pi
sudo usermod -a -G dialout root
sudo usermod -a -G tty openhab
sudo usermod -a -G tty pi
sudo usermod -a -G tty root
sudo reboot

OpenHAB2 on Razpberry - Z-Wave Controller Offline
(Norman) #12

No, that is wrong. I am using a Raspberry Pi 2 and the RaZberry board is accessible via ttyAMA0 not ttyS0 or any other port.

I am trying to run Beta 4 of openHAB2 but it does not find my Z-Wave board. One time it says “port does not exist”, the other time it says “port is in use”. But anyway, it just does not work.

I am actually running a working FHEM-Installation on a second SD card. This works fine with “/dev/ttyAMA0” on the same Raspberry Pi. The port there is “/dev/ttyAMA0@115200”. If I boot up openHAB Z-Wave does not work at all. The previous beta worked without problems on the same hardware.

So I assume something is really wrong with the Z-Wave bindings in b4.


( ) #13

Then could you please try with the latest snapshot build? Instructions here or here.


(Norman) #14

I will.

I had a little success now, after entering the port in HABmin and going back to the PaperUI I entered the port again - after about 4-5 tries it showed the controller as ONLINE, then scanning all nodes. Unfortunately most of them are unknown devices - weird, because I only use Fibaro, AeonLabs and Everspring which I thought are common devices on the market.

Anyway, I will give the latest snapshot a try and report back later.


(BlizzWave) #15

I said Raspberry Pi 3, not 2.
Read the post carefully.
And it should work fine on the Raspberry Pi 2, just change to AMA0 instead of S0:

-Dgnu.io.rxtx.SerialPorts=/dev/ttyAMA0:/dev/ttyUSB0"

(Norman) #16

Yes Sir. I will, Sir. I did, Sir. You are right, Sir. Just missed the “z” :wink:


(Norman) #17

Okay, I did a clean install of the Snapshot. No luck: “serial port does not exist”.

I’ll try and hammer the port into the PaperUI until it works :wink:


(Norman) #18

Another weird behauviour of the PaperUI and the Z-Wave Controller settings:

  • I enter “dev/ttyAMA0” into the port line
  • I get the error message “port /dev/ttyAMA0 does not exist”
  • I enter “dev/ttyAMA1” into the port line (just for testing)
  • I get the error message “port /dev/ttyAMA1 does not exist”
  • I open the config again and /dev/ttyAMA0 is still standing there ??
  • I click ok (or save and use)
  • I get the error message “port /dev/ttyAMA0 does not exist”
  • I open the config again and /dev/ttyAMA1 is still standing there ??
  • I change it to /dev/ttyAMA0 and click ok
  • I get the error message “port /dev/ttyAMA0 does not exist”

Edit:

Well, it works now. I had to add the port to the Java options (as described above) into /usr/share/openhab2/runtime/karaf/bin/karaf - then it worked after reboot. I still don’t know why I have to enter the port into PaperUI and in a shell script somewhere hidden deeply in my system. That doesn’t make any sense.

Anyway, right now it is working. Let’s see how it goes.

And I have reached my reply limit for this topic ?! Huh ?

Edit 2:

Z-Wave works now, it seems. Unfortunately most of my Fibaro motion and flooding sensors and other devices are unknown ?! Also my Everspring flooding sensor is “unknown” - I’ll have to go back to FHEM for the time being, so my house is operated correctly. I hope the missing devices will be sorted out soon - if I can help with that just let me know.

Edit 3:

What a weird system this is: I renamed one of my Fibaro dimmers (Z-Wave Node 16) to “FlurDG” in Habmin - now this node does not show up in the BasicUI nor the ClassicUI. In fact - I can’t do anything with it. And I get a very briefly error message in the PaperUI saying something similar to “database error 500” ?! I guess I will have to dig for log files …


(Stefan Bosnjakovic) #19

Hi,
finally got it working after spending half a weekend on this …
Raspberry 3 with Debian Jessie, Razberry Z-Wave interface, Aeotec Multisensor and OpenHAB 2, latest offline snapshot.
Always encountered the same error message “device /dev/ttyAMA0 not found” in Paper UI - which is actually simply wrong.
After playing around with the setup for hours at some point the error message HABadmin changed to “device /dev/ttyAMA0 in use”, which brought me on the right track.
When I first installed the Razberry interface I followed the instructions given on http://razberry.z-wave.me/index.php?id=24, i.e. I also installed the software to test the interface.
This actually leaves a process running hogging the port.
You just need to switch it off by issung the command “/etc/init.d/z-way-server stop” and follow the excellent tutorial by Chris Jackson (http://www.cd-jackson.com/index.php/openhab/habmin) and your all set :slight_smile:
Hope that helps!


( ) #20

There is also an option to prepare your Raspberry Pi for Razberry in the openHABian Configuration Tool. Everyone using a Raspberry Pi and any variation of Rapbian should be able to use it.

Here you can find everything you need to do, including background infos.