Have 2 ZWave things with same node ID; cannot delete them

Tags: #<Tag:0x00007fe740e97a58>

I have two things with the same Z-Wave node-ID. One thing identifies the correct device; the other identifies as an unknown device. When I try to delete the “unknown device” thing using the Paper UI I get “Error: 409 conflict.” If I try to delete it using REST, I get “Cannot delete as it is not editable.” (I do not know how to change the thing to be editable.) Using HABmin, I get “Error deleting thing!” How can I delete the one unwanted thing? I am running 2.5.10 under Docker on as Raspberry Pi 3

I can’t say if this will work or not, but you do have a device that you have control over right? So what if you put the controller into exclude mode (I think you can do this from HABmin), exclude the device, and then rejoin it to the controller? That probably won’t remove the broken node but it will move the actual device to another node number which should resolve the conflict at least.

If I recall correctly, to remove a node from the device, you must first mark it as failed. Only once the controller thinks it’s failed will you be able to remove it. But it has been many many years since I’ve done this sort of thing so I could be way off base. Hopefully someone more knowledgeable will come along and help.

But I’m going to move this to a category where it’s more likely to get attention.

2 Likes

That is how it is supposed to work in OH but many of us have had to use Windows software to remove a device from the controller when it could not be excluded.

OK. If you don’t have Windows to run the Aeotech software (I assume that’s what you are referring to) I’ve actually had success doing this sort of thing using Open Zwave Control Panel. There’s even a Docker container to run it. :slight_smile:

Here is the Ansible task I use to deploy the image.

- name: Pull/update the ozwcp image and create the container
  docker_container:
    detach: True
    devices:
      - "/dev/ttyUSB0:/dev/ttyUSB0:rwm"
    exposed_ports:
      - "8008"
    image: openzwave/openzwave-control-panel
    log_driver: syslog
    name: ozwcp
    ports:
      - "8008:8008"
    pull: True
    restart: False
    restart_policy: no
    state: present

Notice I don’t actually run it. That’s because you can’t have openHAB and OZWCP connected to the controller at the same time. So I’d stop openHAB and start ozwcp and browse to the web based UI and start messing with the controller.

I tried that once with no success but not in a Docker container. You would need to stop OH or at least the zwave binding before running that though.

This must simply be an issue with openhab configuration since it is not possible to have two devices in the controller with the same node ID.

You should simply be able to delete the Thing. If you want to exclude a node, then put the binding into exclude mode and exclude it. If there is a thing that cannot be deleted, that is an OH configuration issue.

A message of “Error deleting thing” probably does not come from the ZWave binding at all - it will be from the framework since it is not part of ZWave to delete things.

1 Like

Thank you everyone who has offered help and suggestions. I’m sorry that I did not respond soon, but I was out of town last week and was unable to look at the problem. Here is an update on what I have tried and the results.

I was able to remove the device that was initialized by just removing it from the controller.
I was unable to remove the uninitialized device even if I tried to mark it “Failed” or reinitialized it. Every try resulted in “Error 409 - Conflict .”
I could not find a reference to the Aeotec Z-Wave software and was unable to try it for correcting the controller.
I tried to use the Open Z-Wave control panel. The docker image seems to be for AMD64. I tried it on Windows 10, but it did not create a host network, and as a result, I could not test it. Other than starting the container, is there something else that I need to do before accessing the control panel?
I tried to make the control panel for RPi3 from the source. The make for open zwave worked with no errors, but the make for the control panel had multiple errors. Most were related to Deprecated functions and trying make a second time had the error “cannot find -ludev” and “Makefile:73: ozwcp.” I have no experience with make and don’t know how to correct the errors.

Once again, thanks to everyone for their suggestions…I have not corrected the problem and may have to just accept that the uninitialized devices cannot be removed. This is not an aesthetically pleasing solution, but …

As above - it’s not possible to have 2 nodes with the same ID in ZWave. The controller reports nodes in a bitmask - this means that it can either report a node is there, or not - it can’t report 2 nodes with the same ID.

So, if you have 2 things that show the same zwave id, then this is a configuration issue in OH. I’m not sure why you can’t remove them though.

Unfortunately we don’t use open ZWave in the openhab binding, so I can’t really comment on this.

1 Like

SyLabs has Windows software that can remove devices from the controller.

@rlkoshak has used the OZW Control Panel Docker image successfully. The last time I tried using it natively did no go well. openHAB must not be running when using OZW Control Panel since it needs to control the USB stick.

You mean Silicon Labs? ie Silabs? Or is this something else?

Sorry.
pc controller software.

Just checking that this wasn’t something new :wink:

Note that it won’t be able to remove nodes that do not exist - as mentioned already - it’s not possible to have two nodes with the same address so the issue is likely just an OH configuration problem and it would be worth trying to understand what is showing the nodes are duplicated.

1 Like

Thanks for your suggestions. I have been spending the last week, off and on, trying to install Silicon Labs USBXpress and Simplicity Studio 4 on Windows to access my USB controller, a Zooz ZST10, but I must be missing something, which I suspect is very simple since I cannot install the Silicon Lab drivers and the Z-Wave SDK does not appear in Simplicity Studio even though I have downloaded it via the Studio’s Tools menu. Do you have any suggestions as to what I am doing wrong and how to correct it? Thanks again.

Zooz says no drivers are needed for Windows,
image