Having trouble adding Aeotec WallMote FT130-C


i am trying to add the WallMote from Aeotec (Quad Switch) to OH, but it only discovers an “unknown device”. I tried to delete and re-search it a few times as well as leaving it besides the z-wave controller for some time, but it didnt change. I believe there are some different versions of that switch, mine is a FT130-C, bought a few days ago. My OH is 2.3.0.

Is there some way to add it? Can i somehow manually add it?

Thanks in advance!

Take a look at your /userdata/zwave folder and check the device type and device id in the xml file (which is hopefully present):


There is one in the database with 0002:0082, if you have a different one it needs to be added:


It did not generate a XML file there for the unknown device. The device it the database looks promising (didnt find it in other databases…).
Do i have to export from the website and just generate the xml myself? Should i add it as unknown device before or should i add the xml with the switch in the inbox? I seem to be rather inexperienced with z-wave :blush:

edit: the XML export (OH2) from that website looks very different to my existing nodes i have in OH, i assume that’s not good :smiley:

ZWave battery devices can be a bit difficult to operate as they need some configuration before they will periodically wake up. Until this configuration is programmed, you need to manually wake the device - this is normally required a few times after the initial inclusion.

What do you recommend to accomplish that? I set the wakeup interval to 20sec via habmin (paperui returns error 500 when i set the parameter). I had it like that sitting besides the z-wave stick for the night. I also used the “send wakeup notification” of the devioce (hold action button for 3 sec), but that didnt trigger the configuration either. Not sure, if i am doing the right things :slight_smile:

So basicly you say i should wait for the device to get fully in contact with OH, right? Do i use the XML sihui pointed me to after that or should it complete the configuration on its own?

edit: the device shows up on the z-wave network viewer in habmin, but still no XML.

You need to read the manual - every device has a different way to do it.

Did you wake up the device after setting the configuration in HABmin? If the device is still asleep, then the setting won’t change.

Yes, this is needed, but you can’t wait for this - you need to actively wake up the device if it is not already configured. If the device sleeps, and wakeup has not been configured yet, then it will just sleep forever (and forever is quite a long time to wait :wink: ).

It is possible that the device is waking up, but there’s some other issue that is preventing it initialising - if this is the case, then you’ll need to enable debug so we can work out what is happening.

To wake up this device, press and hold the button on the back for about 3 seconds.

Edit: Also, IIRC, by default, this device doesn’t wake up on its own.

Edit2: I use a wake up interval of four hours. It doesn’t seem to hurt battery life too much, and gives you visibility into the battery level so you can tell when to charge it. :wink:

Edit3: Battery level after about 1.5 months.

Well thats what i did, pressing the button for 3 sec. Did it like 10+ times now :wink: the stick changes its blinking pattern for a short amount of time (not for every 3-sec-attempt though), so the button-press is definitly recognized (sometimes). Still no XML yet …

Which logs are best to debug this? Sorry for my probably basic questions, but this is my first contact with z-wave.

I would suggest the following steps:

  • exclude the device from the zwave network
  • put the zwave binding into debug mode (in the karaf console, log:set DEBUG org.openhab.binding.zwave)
  • include the device into the zwave network
  • wake up the device a couple times
  • post the openhab.log file starting from the point when you began the inclusion process

Thanks, i will do it that way.

In the meantime, after some more wake-up-calls, i got my XML. But the switch is now marked “offline”. Interesting :rofl: Im curious if it returns to the land of the living soon :slight_smile:

Can you post the XML here? Specifically, these lines.


I have these values:


The device is online again, it was a problem with the usb-forwarding.

This device is in the DB here, so it should discover as a Fantem FT130.

Now that you have the XML, what do you see in HABmin for the device? Is it still showing Unknown?

I think this was added recently, and won’t be in the 2.3 binding which is being used by @Putzeudel. You will need to use a recent snapshot for this to be detected.

At least it’s working now :slight_smile: .

1 Like

Ok, good to know. The “first added” date was showing this, which wasn’t very informative. :grinning: I should’ve looked at the commits…

First added to database on -0001-11-30 00:00:00. Current released version is 1.

Hmmm - I’ll look at this as… Thanks.

You can also get a good indication from the ID in the URL - at the moment we’re at the top of the 800’s, so it gives an idea of how old entries are at least (this is 860, so it’s only 20 or 30 entries ago - probably just a few weeks).

Still unknown, yes. Do i have to update the complete OH or just a certain piece?

You need to update the binding to the latest snapshot. You will need to do this manually if you are using the 2.3 runtime as uninstalling, and reinstalling when you are on a stable build will just reinstall the same version.

Thanks alot to all of you here, i finally have a “Wall-mount four Button” :slight_smile: