Heatit Z-Water strange behavior

Hi experts,

I have a question regarding the HeatIT Z-Water Z-Wave device (home).
Manufacturer: 019B (ThermoFloor)
Type/ID: 0003:020A
Firmware version: 2.1
OpenHAB version: 2.5.4

The device was recognized by OH2, it was also added. It has 1+10 switch channels:


The device has 10 relays, so I suppose each channel with the sequence number should be assigned to one relay. Channel without sequence number (switch_binary) should be the main switch which turns ON/OFF all other channels.

But what really happens is: the relays are not switched when I turn ON/OFF the switch_binary1-10. Strange is that the switch_binary turns ON/OFF the first relay on the device and also the switch_binary1 in the OH2. Maybe it’s not controlling directly the switch_binary1, but it turns OFF all relays and also restoring the previous state of the relays when I turn it ON.

Do you have any idea?
Thank you for your help!


Here is our database entry along with a copy f the manual.


I’m sorry, but I don’t understand. What should I do? Should I import somehow the configuration file into OH2?

The configuration should be already part of the binding. I thought the documentation & other settings might provide additional guidance until additional help arrives.

OK, thank you. I’ve seen the documentation, but nothing useful there. :cry:
Does anybody own this device?

Somebody must have in order for OH to have the data.

I’ve enabled z-wave debug logging. When I switch ON/OFF the 10th switch I get these messages:

2020-05-28 00:02:24.462 [DEBUG] [rg.openhab.binding.zwave.handler.ZWaveThingHandler] - NODE 18: Command received zwave:device:8b76ba85:node18:switch_binary10 --> ON [OnOffType]
2020-05-28 00:02:24.462 [DEBUG] [wave.internal.converter.ZWaveBinarySwitchConverter] - NODE 18: Command class class COMMAND_CLASS_SWITCH_BINARY for endpoint 10 not found
2020-05-28 00:02:24.464 [DEBUG] [rg.openhab.binding.zwave.handler.ZWaveThingHandler] - NODE 18: No messages returned from converter
2020-05-28 00:02:25.793 [DEBUG] [rg.openhab.binding.zwave.handler.ZWaveThingHandler] - NODE 18: Command received zwave:device:8b76ba85:node18:switch_binary10 --> OFF [OnOffType]
2020-05-28 00:02:25.793 [DEBUG] [wave.internal.converter.ZWaveBinarySwitchConverter] - NODE 18: Command class class COMMAND_CLASS_SWITCH_BINARY for endpoint 10 not found
2020-05-28 00:02:25.793 [DEBUG] [rg.openhab.binding.zwave.handler.ZWaveThingHandler] - NODE 18: No messages returned from converter

Is this information useful?


If you are running a common Linux install in /var/lib/openhab2/zwave there should be an xml file for that node. Posting it here could be helpful.

@chris our main developer ii in the UK so he may not respond this evening.

Sure, here is the XML file:
network_d9cd18a8__node_18.xml (43.1 KB)
Thank you!

I am trying to learn how to interpret the xml file but it looks to me like the other Endpoints before it. We will need to wait for Chris, I am afraid.

OK, thank you very much!

Hello friends! I’ve found and solved the problem. I’ve compared 2 xml config files (from a different node) and I realized that the COMMAND_CLASS_SWITCH_BINARY command class node is missing for binary_switch1-10. I’ve created that node and it started to work. I suppose this configuration file was generated based on definition file “/src/main/resources/ESH-INF/thing/thermofloor/zwater_0_0.xml”, so we should update the definition file instead of changing configuration.
I can’t see any problem in definition file, so maybe some bug in binding during configuration file generation?
The fixed configuration file:
network_d9cd18a8__node_18.xml (47.9 KB)

That xml file is generated from our database. did you try deleting (NOT excluding) and re-adding the node to get the latest binding settings?

What version are you running? That device was last updated 8 months ago and I see the channel defined for Endpoint 10.


Hi Bruce. I’ve deleted the device, stopped the Z-Wave binding, deleted the XML file and then re-added, but same result. Missing COMMAND_CLASS_SWITCH_BINARY.
OH2 was yesterday updated to version 2.5.5 (before update 2.5.4). The z-wave has the same version.

The xml file updated 3 months ago on Github looks OK to me. Do you see anything missing?

EDIT: There were no changes 3 months ago.

Where is this file in linux filesystem?

It is built into the binding jar file.

I have the same version here:

Hi! Any news? When I reinitialize the device the XML file is probably recreated, so after this action the switches are not working anymore. I have to manually fix the XML file.