Heatmiser NeoHub Gen 2


I am new to OpenHAB and am just trying to get it to work with my home devices.

Has anyone managed to get the Heatmiser Neohub Gen2 to work with OpenHAB?
I have tried using the current Neohub binding that is available in the Add-ons, but unless I am doing something wrong, it does not appear to be able to connect to the hub.

In order for the community to be able to help you, define "not working’ and show us what you have done so far.

Thank you.
All I have done so far is to install the OpenHAB software on a test machine in Windows, and then, from Add-ons --> Bindings in the PaperUI, I Installed the Neohub Binding. The installation completed with no errors, but the Binding did not appear in the Configuration --> Bindings (presumably because it is not a v2 Add-On?).

In the Events.log is this entry: [thome.event.ExtensionEvent] - Extension ‘binding-neohub1’ has been installed.
which indicates to me that the binding action was successful

In the readme it shows the required settings: https://docs.openhab.org/addons/bindings/neohub1/readme.html

I edited the neohub.cfg file under the services folder and added in the required hostname entry as the IP address for my Neohub.

I then spotted this entry in openhab.log: [INFO ] [ab.core.service.AbstractActiveService] - neohub Refresh Service has been started
No errors, so, I assume that the service is running.

I waited over 1 minute (based on the default refresh time in the readme) and nothing happened - no update to the logs. I waited a further 15 minutes and still no change.
I shutdown and restarted the OpenHAB runtime. I could see again that the neohub refresh service was started, but there were no further updates

I have very limited knowledge or experience with OpenHAB at this point, but wanted to know if anyone else had already been successful in linking to the Heatmiser Neohub Gen2 as I expect that the existing binding was designed for the 1st Generation Neohubs.

After 24 hours, the neohub service appears to have woken up and is now logging:

[ERROR] [ding.neohub.internal.NeoHubConnector] - Failed to connect to neohub [host ‘’ port ‘4242’ timeout ‘5000’]

I expect that this indicates that the default port is not working. This is a Neohub Gen2, so it is possible that it uses a different port. Does anyone know what port to use for the Heatmiser Neohub Gen2 and whether the Neohub binding works with it?

Hi Graeme, did you ever get this to work?