Help Error Not Communicating Leviton Smart Outlet

I am switching over from Samsung Smart Things hub to openhab2
using openHAB 2.2.0-1 (Release Build) and Aeotec Z-Stick Gen5, Z-Wave Plus USB to create gateway
I mostly have a mix of Zwave devices, all of them added correctly except one outlet. Its a Leviton DZR15-1RZ , I get this error from Paper UI:

Unknown Device

This device has not been fully discovered by the binding. There are a few possible reasons for this -:
The device is not in the database. If the device attributes show that this device has a valid manufacturer ID, device ID and type, then this is likely the case (eg. you see a label like “Z-Wave node 1 (0082:6015:020D::2.0)”). Even if the device appears to be in the database, some manufacturers use multiple sets of references for different regions or versions, and your device references may not be in the database. In either case, the database must be updated and you should raise an issue to get this addressed.
The device initialisation is not complete. Once the device is included into the network, the binding must interrogate it to find out what type of device it is. One part of this process is to get the manufacturer information required to identify the device, and until this is done, the device will remain unknown. For mains powered devices, this will occur quickly, however for battery devices the device must be woken up a number of times to allow the discovery phase to complete. This must be performed with the device close to the controller.

Status: OFFLINE - COMMUNICATION_ERROR Node is not communicating with controller

zwave_class_basic ROUTING_SLAVE
zwave_class_generic BINARY_SWITCH
zwave_frequent false
zwave_nodeid 8
zwave_version 0.0
zwave_listening true
zwave_routing true
zwave_beaming true
zwave_class_specific SCENE_SWITCH_BINARY

Logs here:

2018-04-06 04:52:29.599 [WARN ] [wave.discovery.ZWaveDiscoveryService] - NODE 8: Device discovery could not resolve to a thingType! 7FFFFFFF:7FFFFFFF:7FFFFFFF::0.0

==> /var/log/openhab2/events.log <==

2018-04-06 04:52:29.633 [arthome.event.BindingEvent] - org.openhab.binding.zwave.event.BindingEvent@d11ac9

2018-04-06 04:52:34.767 [me.event.InboxRemovedEvent] - Discovery Result with UID ‘zwave:device:b41dad8a:node8’ has been removed.

2018-04-06 04:52:46.530 [home.event.InboxAddedEvent] - Discovery Result with UID ‘zwave:device:b41dad8a:node8’ has been added.

==> /var/log/openhab2/openhab.log <==

2018-04-06 04:52:46.529 [INFO ] [g.discovery.internal.PersistentInbox] - Added new thing ‘zwave:device:b41dad8a:node8’ to inbox.

==> /var/log/openhab2/events.log <==

2018-04-06 04:52:46.546 [arthome.event.BindingEvent] - org.openhab.binding.zwave.event.BindingEvent@16e163

==> /var/log/openhab2/openhab.log <==

2018-04-06 04:52:46.647 [WARN ] [wave.discovery.ZWaveDiscoveryService] - NODE 8: Device discovery could not resolve to a thingType! 7FFFFFFF:7FFFFFFF:7FFFFFFF::0.0

==> /var/log/openhab2/events.log <==

2018-04-06 04:52:46.683 [arthome.event.BindingEvent] - org.openhab.binding.zwave.event.BindingEvent@2971b9

2018-04-06 04:52:53.923 [me.event.InboxRemovedEvent] - Discovery Result with UID ‘zwave:device:b41dad8a:node8’ has been removed.

2018-04-06 04:52:53.969 [hingStatusInfoChangedEvent] - ‘zwave:device:b41dad8a:node8’ changed from UNINITIALIZED to INITIALIZING

2018-04-06 04:52:53.982 [hingStatusInfoChangedEvent] - ‘zwave:device:b41dad8a:node8’ changed from INITIALIZING to OFFLINE (BRIDGE_OFFLINE): Controller is offline

2018-04-06 04:52:53.998 [hingStatusInfoChangedEvent] - ‘zwave:device:b41dad8a:node8’ changed from OFFLINE (BRIDGE_OFFLINE): Controller is offline to OFFLINE (COMMUNICATION_ERROR): Node is not communicating with controller

Ive tried factory resetting the outlet, I have joined and excluded from the samsung network twice.

Any hints or suggestions?

Solved!. I had to move the controller into the same room as the leviton switch and then it bound correctly. After that I was able to move the controller back to another room and everything functions correctly.