Help, MQTT clientId can't be custom set


I set up an MQTT broker via PaperUI. It works perfectly but I am unable to set a custom clientID. It lets me change other broker settings such as IP address etc but the clientID won’t change, only generates random IDs.


I cannot find the bug report mentioned, but from the posting date any fix will not be included in OH 2.4 release.