Help with Kwikset HomeConnect 620 and Aeotec Z-wave stick

  • Platform information:
    • Hardware: _raspberry pi 4, 4GRam?
    • OS: openhabian/raspbian
    • Java Runtime Environment: whatever was default
    • openHAB version: 3.2 or what ever latest was a couple of weeks ago
  • Issue of the topic:Can’t get OpenHab to recognize the door lock
  • Please post configurations (if applicable):
    • Aeotec Z-stick Gen5, (not gen5+), Kwikset HomeConnect 620 (zwave 700Series)

I am new to this so bear with me… This is a new installation of OpenHab and I’m new to this. I\e successfully connected a number of wifi switches. This is the first z wave device. I have installed the Zwave bridge and it is on line. When I scan for the zwave devices it finds the lock but does not recognize it and does NOT go online. OpenHab can see the lock but apparently doesn’t know how to talk to it.I have fiddled with it a while but can find no way to tell it how to recognize the lock. Now I’m wondering if the z-stick is too old (I think it’s at least 5 years old) to work with this lock. Do I need to get a new z-stick that is zwave 700 series compatible? The documentation for the zstick and for the kwikset lock is pathetic(i have stronger words that would better describe it.).
Can anyone tell me if these are compatible or if they are where I might find better documentation to set this up? or maybe point me in a direction to resolve this.
Thanks in advance.

Don’t go doing that. 700 series sticks are not yet compatible with OH. There’s ton of info about the drama surrounding the roll-out of the new Z-Wave api here on the forum if you’re interested.

There are probably a couple of things going on. First off is the Z-Wave database. In order for a Z-Wave device to be compatible with OH it has to appear in the community-maintained database of devices. This is what allows OH to understand how to translate the Z-Wave functions and parameters into OH things and channels. You can find the database here: OpenSmartHouse Z-Wave Device Database .

When you look up the Kwikset 620 in that database you’ll notice that an entry exists but it has not yet been fully finalized. In order to help move this along, you’ll want to follow the instructions on the site to get edit rights and probably file a ticket to find out why it has not yet been approved.

Once the entry gets approved the device isn’t automatically there in your OH instance. You’ll have to wait a few days for the updated database to get compiled into a new binding jar and then either update your OH to the latest snapshot or just manually install the jar (lots of instructions around for both options).

After all that, you might be able to get the lock talking to OH, however, there’s still one more possible hurdle. Devices such as locks have to be securely included in the Z-Wave network (for obvious reasons). If you are still having trouble with the lock after the database issue is resolved, then it’s possible you have to exclude the lock from the network and re-include it securely (if I recall, this means factory resetting the lock and initiating the include within 15s of the reset).


Thank you very much. That was very helpful. Both of the devices are in the database but, as you said, the Kwikset 620 is not approved. (I can’t say B&D. I really don’t like them. Apparently quality is a word they don’t understand.) That kind of surprises me as I thought the 620 would be pretty common. Oh, well… I’ll go write that ticket and see if I can get it going.

Well, I’m making progress but I still need help. I created a ticket at the z wave database but had not heard anything as of when I checked a couple of hours ago.

However, in continuing to fiddle I finally got the lock to go online and now have this in the Thing info:


Think Type   Unknown  Device
This device has not been fully discovered by the binding. There are a few
 possible reasons for this -:

    The device is not in the database. If the device attributes show that this 
device has a valid manufacturer ID, device ID and type, then this is likely the 
case (eg. you see a label like "Z-Wave node 1 (0082:6015:020D::2.0)"). Even 
if the device appears to be in the database, some manufacturers use multiple
sets of references for different regions or versions, and your device references
may not be in the database. In either case, the database must be updated and 
you should raise an issue to get this addressed.
    The device initialisation is not complete. Once the device is included into the 
network, the binding must interrogate it to find out what type of device it is. One 
part of this process is to get the manufacturer information required to identify 
the device, and until this is done, the device will remain unknown. For mains 
powered devices, this will occur quickly, however for battery devices the
device must be woken up a number of times to allow the discovery phase 
to complete. This must be performed with the device close to the controller. 

Thing Properties  16
    zwave_class_basic    BASIC_TYPE_ROUTING_SLAVE
    zwave_class_generic   GENERIC_TYPE_ENTRY_CONTROL
    zwave_frequent    true
    zwave_listening    false
    zwave_version   7.20
    zwave_plus_devicetype   NODE_TYPE_ZWAVEPLUS_NODE
    zwave_deviceid    9128
    zwave_nodeid   4
    zwave_routing     true
    zwave_plus_roletype    ROLE_TYPE_SLAVE_SLEEPING_LISTENING
    zwave_beaming    true
    zwave_secure    true
    zwave_class_specific     SPECIFIC_TYPE_DOOR_LOCK
    zwave_devicetype     2065
    zwave_manufacturer     144

I am communicating with the lock from OpenHab as I am able to set/change keycodes. However, I can find no way to set do an actual lock/unlock. One thing that is bothering me is that I don’t see any channels associated with the lock or any way to add/find channels. I expected to need a channel to setup Equipment from a Thing.
Any suggestions?


You simply won’t see any channels until the database entry is active; there’s no way around that.

Thanks. I was hoping that since I got it to go online in a secure mode that there would be enough functionality to work. Alas, I miss the days of smacking the radio/tv on the top to make it work.

The z-wave database entry for this lock has been approved now. Though the lock still shows up as online but it still says it is an unknown device. The device info says that it may take awhile for the device to do it’s discovery process and may need to be woken up several times. How might one wake up the device? I can change/add lock codes but don’t know how to make it do the rest of the discovery process. Any suggestions? Do I need to delete the lock and re-scan for it?

I’m not sure about locks, but that is the normal procedure to pick up DB changes with other devices. (after of course either OH3 or the z-wave binding is updated to the snapshot version that includes the change)

Ok deleting and re adding didn’t help.
The data base entry says

Last Approval 2022-08-08 23:29:03 OH-SNAPSHOT

So how do I tell if OH has the mod rolled in? Where do I find instructions for updating my OH? I have not found my way around in OH or in the documentation. Though I’m a retired programmer and consider myself technically competent, this is a new world for me. I know a jar has something to do with Java but I’ve never been there.

Also, this is a new installation so it would not be a big deal to restart from another new install.

I usually just install the snapshot zwave binding to minimize chances of picking up a bug from the other changes in the OH distribution. The latest zwave binding is here. The update procedure for that is

However, you should be able to check what zwave binding you have with
bundle:list |grep ZWave in the Openhab-cli console also. It looks like it needs to be dated Aug 9 something


edit: again still not sure about locks. May actually have to exclude then reinclude to get the security key correct, but try the easier way first.

I finally figured out how to get to the openhab cli. I was expecting to be in a nice command line window but “Toto, I’ve a feeling we’re not in Kansas anymore.”
Anyway, I managed the feature:install step. Then using shell:ls and shell:cd I cannot find an openhab/addons directory. And I don’t know how to copy from the Jenkins zwave site to anywhere in this environment. I tried poking around in the other directories but don’t know what I’m looking for.
I tried doing the

bundle:list |grep zwave

Or is grep case sensitive. I just noticed i don’t have the same case as above.

Any pointers would be appreciated.
On a side note I was unable to simply connect my monitor and keyboard to the raspberry and login. It never gave me any command prompt. I think I remember logging in as admin on my previous installation attempt. Did I forget to enable something during installation?
Sorry for being so dense but I do feel like I been dropped into Oz.

I’ll try, but there is documentation of openhabian :wink:
Probably most helpful is if samba was setup by openhabian. I’m basically a windows person, so how to do some of this from the command line of the Rpi would be tough for me to explain since I don’t use that. Probably one of the linux people can help…
I have the key OH folders visible via the Samba setup on my windows machine and simply download the jar to my downloads folder and drop in the OH via file explorer

the folder is here(I believe this is a symlink location, but it should work.

edit: ZWave is case sensitive. I did it wrong the first time too

Oh. that is part of it. When I login to openhab it puts me in that home directory. I didn’t know I needed to be looking in /srv from the root dir.
I still need to figure out how to copy the file over there. I can ssh into the raspberry so that may be the easiest way. I’ll let you know.
As for documentation it is written clearly for someone who knows what they are doing. if one is unfamiliar with the software environment and/or tools and the usage environment (home automation, in this case) then things are not so clear. It could as well be written in another language. That has always been what I have always found when I move into something new. That’s why the newbies frustrate the Old-hands so. I try to read the docs because I’ve been on the other side but it is a slow process coming up to speed.
I really do appreciate your help.

1 Like

I think I’m almost there…
I got the file copied over and deleted and reloaded the lock thing and zwave bridge and re-scanned but I’m seeing the same unknown device for the lock thing.
The bundle:list command gives:
266 │ Active │ 80 │ 3.3.0 │ openHAB Add-ons :: Bundles :: ZWave Binding
269 │ Active │ 80 │ │ openHAB Add-ons :: Bundles :: ZWave Binding

It looks like I have two zwave bindings? The second one has the date I’m looking for.
What did I miss deleting?

Yes. Needed to uninstall zwave from the ui first. The safest is to remove the 3.4 snapshot and uninstall from the ui. Then readd the 3.4. You may need to restart oh if the zwave things do not come online. Then delete (Not exclude) the thing and scan again. See if that works.

I had just deleted the Things. I went back and deleted and reinstalled the things and the binding and now it recognizes the Device. I’m thinking all is good. I’m now going to try to add as equipment and see if I can control it.
baby steps…
Thanks again for all your help,

Sounds good. If things go astray get to one zwave binding, if you still have both.

I now have the Lock thing recognized and I can see 6 channels available. On the channels page of the lock thing I select all and do Add Equipment To Model. An item for each channel is created for that channel.
I go to Pages Overview page and add a toggle card and on the toggle card edit page select the door lock Item that was created. When I go to run mode or go to that page it does not work. I don’t know how to tell what is not working.
I do have a wifi light switch working on this page. Though that is much simpler I think my process is right.
I haven’t found any documentation that is helpful here. Can anyone give me any insight into what to look for.

Ok Back to the openhab-cli. This time log:set DEBUG org.openhab.binding.zwave. try the switch both from the toggle and from the list of items. Then set the log back to INFO. (I do not think these are case sensitive). You’ll see if the command is being sent and if the Node is responding.

Edit: could also try opening the lock

Ok. Thanks. I’ll give that a shot. I’m certain it is something dumb I’m doing but I can’t see it. One thing that puzzles me is that when it creates the lock channel item it is a point and not a switch.I’m not sure what that means.
The lock works manually from the keypad so it is “functioning” and I can set lock codes from the thing so their is some communication. But don’t see it responding to anything else remotely.