Help with OpenHAB on Ubuntu 16.04

After following the wiki from top to bottom ( but I am a bit confused because OpenHAB site says to put in all in /opt/openhab and the wiki says /etc/openhab is there any major issue there? I have put the repository in Ubuntu Software Center and tired to load it that way but I did not get any success. Here is where I am at right now I built a 16.04 Ubuntu server that will be used to operate all home automation. I create a user in my name but I think I should have created an “openhab” user since several sites mention that. I tired to follow what they had on the Get Starting part of OpenHaB but extracting the files to /opt/openhab but found I was missing a bunch of steps like MySQL, Samba, OpenSSH, and Mosquitto so no workie there. Then followed the Wiki but go to the bottom and no joy. I have rebuilt the server 10 times and frankly about to give up any help in the right direction would be great…

Thanks ahead

On Ubuntu you should install using apt-get. For openHAB 1.8.3 those instructions are b here

For openHAB 2 those instructions are here.

In both cases the openhab use will be created as part of the install and everything gets put in the standard places fit debian based Linux like Ubuntu.


Thanks I will try that. I did do it the first time by using apt-get but no joy in the end. I will go by these instruction then. I am glad to see a Openhab2 instruction I wanted to go that route but couldn't figure it out. 

Thanks again,

Ok going good so far but found I cannot do the Snapshot due to missing files.

There is a known bug with the snapshot build right now that is causing problems for apt. I too am awaiting that bug to be fixed soon.

Thanks everything is working now.

I am still unable to install snapshot for OH2 with apt. Has this been fixed or am I missing something?

I had the same issue and was told the snapshot was having problems. I tried it again and it loaded, so not sure what the issue was at that time.

What is the most simple way to install openhab 2 manual or package?


I just started my openhab 2 projekt. I installed Ubuntu 16 and also Java, and maybe OpenHab2, when i try to use ubunty seach I cant find any Ubunty, so maybe the installation did not work?

Shall I try to install Open hab again, and if so, what is the most simple way?

Looks like this
camilla@CamillasDator:~$ sudo systemctl restart openhab2.service
Failed to restart openhab2.service: Unit openhab2.service not found.



I did the guide again with no Joy, How do i check if OpenHab is installed? ( on Ubuntu )

You will have an /etc/openhab2 folder.

But if you followed the guide and Oh did not install you had an error somewhere along the line which would have been shown to you.

So what errors did you see?


Yes I got that folder and I did nopt got any error messages. However when I tried to install Openhab when I hade win8 installed I got to a setup pager during the end off the install. But not when I installed OpenHab on Ubunty, and I dont understand how to login to my openHab so can try to setup my IP camera and do my basic setup.

http://<ip of machine>:8080


Problem accessing / Reason:

Sitemap 'default' could not be found

Caused by:

org.openhab.ui.webapp.render.RenderException: Sitemap ‘default’ could not be found
at org.openhab.ui.webapp.internal.servlet.WebAppServlet.service(
at org.eclipse.equinox.http.servlet.internal.ServletRegistration.service(
at org.eclipse.equinox.http.servlet.internal.ProxyServlet.processAlias(
at org.eclipse.equinox.http.servlet.internal.ProxyServlet.service(
at javax.servlet.http.HttpServlet.service(
at org.eclipse.jetty.servlet.ServletHolder.handle(
at org.eclipse.jetty.servlet.ServletHandler.doHandle(
at org.eclipse.jetty.server.session.SessionHandler.doHandle(
at org.eclipse.jetty.server.handler.ContextHandler.doHandle(
at org.eclipse.jetty.servlet.ServletHandler.doScope(
at org.eclipse.jetty.server.session.SessionHandler.doScope(
at org.eclipse.jetty.server.handler.ContextHandler.doScope(
at org.eclipse.jetty.server.handler.ScopedHandler.handle(
at org.eclipse.jetty.server.handler.ContextHandlerCollection.handle(
at org.eclipse.jetty.server.handler.HandlerCollection.handle(
at org.eclipse.jetty.server.handler.HandlerWrapper.handle(
at org.eclipse.jetty.server.Server.handle(
at org.eclipse.jetty.server.AbstractHttpConnection.handleRequest(
at org.eclipse.jetty.server.AbstractHttpConnection.headerComplete(
at org.eclipse.jetty.server.AbstractHttpConnection$RequestHandler.headerComplete(
at org.eclipse.jetty.http.HttpParser.parseNext(
at org.eclipse.jetty.http.HttpParser.parseAvailable(
at org.eclipse.jetty.server.AsyncHttpConnection.handle(
at org.eclipse.jetty.util.thread.QueuedThreadPool.runJob(
at org.eclipse.jetty.util.thread.QueuedThreadPool$

I tried to create a sitemap file, but still have the same problem

try http://<ip>:8080/start/index

When you create a sitemap file, what did you put in the file and where did you put it?

Did you install the snapshot or 2.1?


tryed this with no succes

I belive i installed OpenHab 2.1? How can I check with version I am running?

And the answer to my other question?