Help with plugin development


I wonder if someone could give me a helping hand.

I would like to develop a plugin so have started by following the tutorial video by Kai.

Everything works up to the point where I want to add in a new ‘thing’ but my new plugin does not show any ‘Supported Things’ in the list.

The debug log shows the thing-types.xml being loaded and I can’t see any errors at that point. I am absolutely sure it is something blinding obvious but I cant see it for the life of me.

Any help would be very gratefully received!

My binding.xml and thing-types.xml look like :

(I had to put a space in h ttp in the below because the forum didn’t like me posting links as a new user!)

<?xml version="1.0" encoding="UTF-8"?>

<binding:binding id="beesnest"
xmlns:xsi="h ttp://"
xmlns:binding="h ttp://"
xsi:schemaLocation=“h ttp:// h ttp://”>

<name>BeesNest Binding</name>
<description>This is the binding for BeesNest.</description>



<?xml version="1.0" encoding="UTF-8"?>

<thing:thing-descriptions bindingId="beesnest"
xmlns:xsi="h ttp://"
xmlns:thing="h ttp://"
xsi:schemaLocation=“h ttp:// h ttp://”>

<!-- Sample Thing Type -->
<thing-type id="sample">
	<label>BeesNest Binding Thing</label>
	<description>Sample thing for BeesNest Binding</description>

		<channel id="channel1" typeId="sample-channel"/>

<!-- Sample Channel Type -->
<channel-type id="sample-channel">
	<label>BeesNest Binding Channel test</label>
	<description>Sample channel for BeesNest Binding</description>


Thanks very much


How annoying.
I think that it was the browser all along rather than the plugin.
As soon as I tried it in Chrome or Edge rather than Internet Explorer, everything worked…