Help with zigbee thermostats (Sinope TH1123ZB)

I was able to pair them without any issue using the zigbee-binding, but I’m not seeing the channels I’d expect:

electrical_rmscurrent - 0-7 (seems about right)
electrical_rmsvoltage - 2425.0 (V*10 I guess?)
electrical_activepower - always blank
measurement_temperature - seems accurate, but extremely delayed. Up to an hour. “Refresh Items” in HABmin DOES grab the current value immediately, so I guess these thermostats just doesn’t push updates often enough and require polling?

And most importantly there is no channel for TargetTemperature/setpoint, rendering it completely useless. The manufacturer’s website is somewhat vague, but indicates that it can be controlled via zigbee “if supported by your Zigbee-compatible hub and its application”.

There’s also a SmartThings driver for it here that mentions zigbee and what look like memory addresses. I suspect this is what’s needed to make it work, but I have no idea what to do with it. Any help would be great. Thanks.

Sinopé TH1123ZB
OpenHAB 2.3 (portable version)
Telegesis ETRX3USB /w Silicon Labs VCP Driver
OSX 10.12.6

Edit: It seems this isn’t an issue with the thermostats after all. The zigbee binding just doesn’t yet support viewing/changing the setpoint. Not sure how I missed that. Oh well.


I’ve just ordered a thermostat to play with so I can look at adding support for this in the near future - hopefully yours will be similar in functionality…

Just off the top of my head there’s a few variations to consider though.
-setpoint single/dual/quad(does anything actually use quad?)
-threshold user-configurable?
-mode off/heat/cool/auto which are available?
-aux heat user-controllable?

Mine is super basic though so I expect any support at all will make it work. Fingers crossed.

Let’s hope there’s enough commonality as there’s only so many devices I can afford to buy in the name of testing :slight_smile: .

Any updates on this? Would be super interesting for me in order to control my floor heating.
Thanks in advance!

Hi, any updates on this? I’m still trying to find a line voltage (240V baseboard) thermostat to work with openhab…

I added a number of Thermostat channels to the binding a few weeks back.

Excellent! Thanks!

Hello, @chris. I’ve updated to a recent build (1549), which I think should include the aforementioned zigbee thermostat channels. I removed my Stelpro Maestro via Paper UI, stopped openhab, removed the zigbee xml file, restarted openhab, and re-discovered the device.

It shows up in the UI, but the only channel it sees is Humidity. This unit does have an issue where the name which is picked up by openhab has a bunch of garbage characters in it. That might be breaking the identification of device type?

The gist of the log is here:

Please let me know if there is anything else I can provide. Thanks!

I finally got around to testing this on my own thermostats. I can now see the setpoint via the ‘Occupied Heating Setpoint’ channel, but changing it has no effect on the actual thermostat.

Sorry - I missed this message (quite some time ago obviously!).

This probably isn’t causing an issue, but it also should not occur. I just checked this in the latest libraries and it doesn’t happen there so I think it’s been fixed.

I will take a look at the thermostats stuff over the next day or so - I’ve just hooked one up here for testing for another customer so can finally test this :slight_smile: .

Fantastic! Would love to get my thermostat working with openHAB!

Hello @chris! Any update on this? Thanks!

No - unfortunately for the past few weeks the development environment is broken so I can’t do anything on the binding until this is resolved - sorry.

Wow! Looking trough the comments in gitlab and the other discussion, it seems like implications of repo changes weren’t communicated/coordinated by the maintainers? Anyway, best of luck getting that sorted out!

I’m not sure they were understood - let alone communicated as there is still plenty of discussion going on about how to get this all working.

I have the Verdant thermostat set up here at the moment, so once this all sorts itself out I will take a look at it.

Hello, @chris! I believe, looking at the Github tickets, that the build problems have been resolved? Any progress on the thermostats? Thanks.

I’m not sure what you have been looking at as there are a number of issues open about this, but unfortunately no, it is far from resolved.

You can find the latest comments below, but it seems that at least myself and Kai are having big problems, and others also -:

Ok, I see that the original issue I opened and referenced above was closed - that is what you are referring to.

That’s the joy of github - Kai wrote in another PR that that PR closes the original issue, so it is automatically closed when the PR is merged, and we don’t see this getting closed. Unfortunately, it didn’t fix the problem, but the issue is still closed.

I’ve managed to get an IDE working - finally - even if it’s still got a lot of problems…

I’ve just linked a thermostat, and while it looks like there are some issues (the mode doesn’t allow commanding, and the running mode seems to have an issue), however, in general it identifies the channels, and they are updated when I change the configuration on the thermostat itself.

I’ve had a look through your log, and don’t really see anything that should prevent your device working also - it’s identifying the same clusters as I’m expecting in the binding. So, I suspect that there may be an issue with your device and it’s possibly throwing an exception somewhere that is preventing the channels being discovered. That’s a guess since I don’t see anything in the log.

So, I recommend that we start with the latest binding - I’m just about to publish a new version in a few days. The latest version will resolve the issue with the corrupted device name - this was fixed a while back. I will try and resolve the issues I see here with the setting of the modes, and setpoints, Once we have that let’s see how we get on with finding the cause.