Home Connect binding

there was an issues with the homeconnect server today. Maybe you can check again. Or if this does not work, try to authorize your bridge again.

Hi Thanks for the quick reply.
I’ve authorized my bridge again. No change.
When the dryer is turned off (no Wifi), the Cloud says connected is false. When I turn it on connected changes to true. The Status stays OFFLINE and in Openhab it seems dead.


Hi Michael,

I think the Home Connect API had a problem yesterday (maybe today too). Can you send me your request log export? I will have a look.

My appliances have bee experiencing trouble since Sunday. I wonder if it is because of the change from summer to winter time?

Hi @jb4711 is it possible to send refresh to a device to force a refresh?


it should work to just send a REFRESH command.

I’m pleased to announce the availability of a new binding version.

Code and documentation can be found at https://github.com/bruestel/org.openhab.binding.homeconnect/tree/2.5.x-next/bundles/org.openhab.binding.homeconnect

Download: org.openhab.binding.homeconnect-

Change log:

  • new binding UI
  • improved stability
  • added connection recovery mechanism in case of error
  • improved offline/online detection
  • applied code changes (to be accepted as official binding)
  • code cleanup
  • new SSE client
  • improved API calls to prevent hiding Home Connect rate limits

@AndrewFG, @MichaelHeimann, @stevendp, @Lolodomo, @harald_knoll, @Lodewijk, @Pascal_S, @Channel

1 Like

Hi Jonas.
Thank you very much. :+1::+1::ok_hand:
One question. Should i remove all old things before i update the jar file?

Yes please.

Hi Jonas,

Thanks! Nice new UI in the console!
Should setting the venting level and program for the Hood work? In PaperUI it doesn’t seem to work or how should I use it?



Hood changes are not included in this ‘release’. Working on that right now.

Aha ok, then that’s expected :slight_smile: FYI, to set the automatic program the following can be used: curl -X POST --header “Content-Type: text/plain” --header “Accept: application/json” -d ‘{“data”:{“key”:“Cooking.Common.Program.Hood.Automatic”}}’ "http://localhost:8080/rest/items/NeffAfzuigkapNEFFD96IKW1S068A40E088639_ProgramActions”

No urgency as I can make it work with these calls as well :wink:

Hey @jb4711
very nice binding. all information works well for my Oven BOSCH-HBG676EB6
i’m right that i only can switch the oven on/off but can not start the selected program?
will that be possible in the future?


Yes, you are right. I think you are only able to start a program or stop (not sure). It might change in the future.
For further information please have a look at https://developer.home-connect.com/docs/authorization/scope

Hi @jb4711,

Is the neest version of the binding working with OH3 M2 ??


Not yet. I work on that. Currently I work on hood support. Afterwards I will focus on OH3.


New version available:
Download: org.openhab.binding.homeconnect-

Change log:

  • full hood support (big thanks to @stevendp for his help)

What about Functional Light and Ambient Light?

I’ve put it on my todo list. Must be a new feature, haven’t seen it before in the documentation.

Hi Jonas

The feature has been in the API at least since January. Back then I added it to your code while experimenting with using Visual Studio Code for Java development and have been using it right up until you made you version 2020/09/11. I use it for turning ambient light on in my kitchen in the evening.

I was waiting for you to move to the OpenHab branch before making a pull request. Its been quite a long time, but when you start implementing this, I can send you my changes.I haven’t had time to merge my changes into your recent changes, so its based on your code from February.