Homegear install

Hello Oliver,

I’m happy to see, you got homegear running on openHABian 1.7. I also want to reinstall openHAB and have now tried numerous ways to get homegear to run. Unfortunately unsuccessfully…

Did it work for you as described at homegear.eu?

sudo -s
wget -O /tmp/HomegearInstaller.sh https://downloads.homegear.eu/HomegearInstaller.sh && bash /tmp/HomegearInstaller.sh

When I try it this way, I always get an error message.

Hi Tobias,

I am sorry that I did not take notes. But yes I installed the nightly build like decribed.
I have the following version running:

>homegear -v
Homegear version 0.8.0-3468
Copyright (c) 2013-2020 Homegear GmbH
Required library versions:
  - libhomegear-base: 0.8.0-3468
  - libhomegear-node: 0.1.8-60
  - libhomegear-ipc:  0.1.2-46

Included open source software:

- Node.js (license: MIT License, homepage: nodejs.org)
  - PHP (license: PHP License, homepage: www.php.net):
      This product includes PHP software, freely available from <http://www.php.net/software/>
      Copyright (c) 1999-2020 The PHP Group. All rights reserved.

Thanks for your quick reply! After several attempts, the installation has now worked, although I am not aware of having done anything differently… As I’m a bit later I got Homegear version 0.8.22012502-3490 and so on. After this installation I did as described in the BidCoS-Manual.

But when I type homegear -r I get

Could not connect to socket. Error: No such file or directory

Does anyone have an idea what else to do to get the HM-MOD-RPI-PCB to run? On my OH 2.4 everything worked fine.

Hi Tobias,

try it with sudo … I had the same.
I mean:

sudo homegear -r

Seams to need root rights now. Was also different for me in old installation.

Thanks again! It actually worked. Now I just need to get the pairing right. That unfortunately still makes problems after countless attempts…