Homekit addon - lags when switching from WIFI to cellular

home wifi : raspberry pi, openhab with homekit, iphone
Apple TV with homehub turned on

Everything runs smoothly if i am in WiFi range or completly out of WiFi range but often when i am accessing gate item wifi is poor and switching to cellular - during these few secunds homekit lags.
Is there any working software solution? it is very annoying.
Of course i can extend wifi network range using a repater any other ideas?

I am making some assumptions since your question doesn’t describe the environment very well but here goes.

Sounds to me like HomeKit is probably fine, if someone was to send a command to one of your smart devices from another well connected source it would most likely work at the exact same time you’re experiencing this lag.

The problem is more that your iPhone can’t get the message to the HomeKit Hub due to the poor connection. As you already know it can take some time for the iPhone to Detect it has poor Wifi and switch to Cellular - Especially when still in range of WiFi but just barely (because it might be getting some success at sending messages but not 100% success, which in turn extends the detection time).
Needless to say this is an iOS feature that Apple is in control of and unlikely to change, so you really only have a few options.

  1. Turn off WiFi entirely and only connect via cellular (Probably the best option to avoid this issue) of course this may not be an option if you’re not on some sort of unlimited plan that you can essentially forget about any data usage fees. because you would be doing all internet stuff via cellular connection (Updating Apps, Steaming Video, etc…) or your cellular signal is also poor at this location.

  2. Find a way to make your WiFi network reach this location. Move the Wifi Router to a more appropriate location if possible. If the network is still strong at the location your wanting to use it from (near the gate it sounds like) then the lag will not occur.

  3. Extend the WiFi network with more access points. This is what I did myself and would work in most situations. I have installed a WiFi access point at each end of my house and they provide excellent coverage, but I run into a similar issue that you do when I walk from one side of the house to the other. While I am still connected to the WiFi on the other side of the house it will not instantly switch to the other node because it still thinks it might have a chance to get the messages out. So extending the WiFi network works best with not too much overlapping between the access points range. In my case while I now have much better WiFi in the Front Yard, Back Yard and Garage I have to deal with the lag issue quite often. At this point I have trained the family how to provoke the internet to come back when you move accost the house (so slightly annoying and not exactly the result I was hoping for). works great to stationary WiFi Devices but not so much for mobile ones. Guess I just need a bigger house :stuck_out_tongue:

  4. Toggle the Wifi in settings. For the moment this is the solution my family uses when lag happens. On the iPhone open the settings app and turn off WiFi and turn it back on again. This will force my iPhone to renegotiate a connection to the WiFi and in doing so it picks the access point with the best signal and I am back up and running (although still grumbling about the extra time spent). This works for me because I’m connecting WiFi to another WiFi. In your situation you would simply leave off WiFi. then the phone moves to Cellular and your back (The real problem is remembering to turn WiFi back on later to avoid Cellular data usage). For me at least the act of toggling the WiFi off and back on is faster then just waiting for the phone to figure it out itself.

As far as I know it is not possible to force an App to use a specific interface on iOS. the system is in charge of that not the App. So the choices are not necessarily the best but I would choose the one that would be most acceptable to me and go that route.

This topic was automatically closed 41 days after the last reply. New replies are no longer allowed.