HomeKit bridge node.js problem

Hi, sorry for yet another beginner question :frowning: I feel like I’m 1 step forward and 5 steps back at the moment.

I’m trying to install the openHAB HomeKit bridge that’s here

I get up to the npm install part but it doesn’t work, it seems to say that node.js didn’t install right. I tried to install from a tarball but that didn’t work but then I tried http://weworkweplay.com/play/raspberry-pi-nodejs/ and it seemed to work. This is a RPI2.

However I now get loads of errors when I try to run npm install, something about dependencies missing? I’ve tried to read lots of info on installing node.js and its dependent libraries but this one seems to be beating me.

Could you share the terminal output that results from attempting to install npm?

@Iain_Attenborough I also had issues with npm install on my rPi.
Was fixed by reinstalling node using the following instructions: https://github.com/nodesource/distributions#debinstall

Specifically, I did this:

# Using Debian, as root
curl -sL https://deb.nodesource.com/setup_4.x | bash -
apt-get install -y nodejs

Now these versions should be installed:

$ node -v
$ npm -v

Now checking out OpenHAB-HomeKit-Bridge and npm install works again.
Only problem I still have is that HomeKit doesn’t see the bridge, but that’s another issue :smile:

I would be grateful on hw to install home kit bridge on a raspberry pi 2.

I tried the above but I get loads of errors when running npm install.

it seems that node-gyp rebuild fails.

gyp info it worked if it ends with ok gyp info using node-gyp@0.12.2 gyp info using node@0.10.29 | linux | arm gyp ERR! configure error gyp ERR! stack Error: Python executable "python" is v3.4.2, which is not supported by gyp. gyp ERR! stack You can pass the --python switch to point to Python >= v2.5.0 & < 3.0.0. gyp ERR! stack at failPythonVersion (/usr/share/node-gyp/lib/configure.js:106:14) gyp ERR! stack at /usr/share/node-gyp/lib/configure.js:95:9 gyp ERR! stack at ChildProcess.exithandler (child_process.js:645:7) gyp ERR! stack at ChildProcess.emit (events.js:98:17) gyp ERR! stack at maybeClose (child_process.js:755:16) gyp ERR! stack at Socket.<anonymous> (child_process.js:968:11) gyp ERR! stack at Socket.emit (events.js:95:17) gyp ERR! stack at Pipe.close (net.js:465:12) gyp ERR! System Linux 4.1.7-v7+ gyp ERR! command "nodejs" "/usr/bin/node-gyp" "rebuild" gyp ERR! cwd /home/steffen gyp ERR! node -v v0.10.29 gyp ERR! node-gyp -v v0.12.2 gyp ERR! not ok

So Apparently my python version is too new (Jessie)

not sure how I can downgrade python without braking anything else…