HomeKit Integration - No connection

I use the IOTstack with opehHAB 3.2.0 on a Raspberry 4. The admin page can be accessed but I cannot connect my iPhone to HomeKit.

My docker-compose.yml looks like this:

container_name: openhab
image: “openhab/openhab:latest”
restart: unless-stopped
network_mode: host
- “/etc/localtime:/etc/localtime:ro”
- “/etc/timezone:/etc/timezone:ro”
- “./volumes/openhab/addons:/openhab/addons”
- “./volumes/openhab/conf:/openhab/conf”
- “./volumes/openhab/userdata:/openhab/userdata”
- EXTRA_JAVA_OPTS=-Duser.timezone=Etc/UTC

What do I have to configure to connect to the IPhone?

Thanks for a reply

can you see openHAB bridge in home app? if not, then the issue is with multicast DNS (mDNS). it can be an issue with docker or with the router in your network

if you can see openhab bridge in home app, but cannot connect/pair, then the issue is with the port 9124. it must be accessible from outside of raspi.

Thanks for the answer.

I have adjusted the configuration in docker-compose.yml and the network is now no longer host

2021-12-29 17_44_07-C__Users_ocliv_AppData_Roaming_Notepad++_plugins_Config_NppFTP_Cache_pi@192.168.

However, I do not know if it is correct.

With the portscanner on the IPhone it looks like this:

However, the openHAB bridge is not visible

My configuration in openHAB

No connection can be established with the scan of the QR code. When I install openHab without Docker it works.

one more thing to check quickly. the IP address configured in the homekit settings. it looks different to raspi ip address visible to outside.
could you try to set the same Ip address in homekit settings? potentially, you would need to switch to host mode again.

Thanks for the tip. I changed the address in the Homekit settings and changed it back to host. It worked :smiley:. Thanks a lot

1 Like

This topic was automatically closed 41 days after the last reply. New replies are no longer allowed.