HomeKit iOS 11 Problem Openhab 2 doesn't found

ios
openhab2
homekit
Tags: #<Tag:0x00007f1824536298> #<Tag:0x00007f1824536130> #<Tag:0x00007f1824535e88>

(Fabian) #1

Hey guys,
I have a problem with my openhab2. I updated my iPhone to iOS11 and I have no differences to iOS10 with homekit. Openhab2 Work fine but today the lights and stuff woun’t answer, so I try to reconnect openhab to homekit. It doesn’t work.
I also try to reinstall the Misc homekit and change the homekit-code, also doesn’t work.

If you have any idea to fix the problem would be fine.
Thx


(algermi) #2

hello everybody,

I have the same problem. Also iOS11 beta.
I have also installed everything completely new, but without any success.


(Anthony ) #3

I am also having the same problem i can get homekit to start connecting but it fails and says unable to connect to openhab is there a fix for this please help???


(Anthony ) #4

(Im also on ios 11 beta 4)


(Fabian) #5

I tried now some things out to fix it. What I found out was:

  • The Problem was Not openHAB.
  • If you use an iPhone with iOS 10 and same Apple id you can use it on the iPhone with ios11
  • if you restart raspberry pi with openHAB you Must enter the console to reset the HomeKit pairing with the command „smarthome:homekit clearPairing“

But thats Not a real Solution

My though was that Apple use in iOS 11 HomeKit now a Software License to varify the HomeKit Produkts. Before they use a Hardware Chip for that. Thing thats make the difference.


(algermi) #6

Hi, no, this is not an ios 10 problem. With me went with ios10 so far everything perfect.
There must be a problem since iOS 11. the repairing solves not the problem to connect iOS 11 devices to openhab2 with home kit. since ios 11 there is now way to connect to opnehab 2 over home kit.


(alex_bartis) #7

Can confirm. Been tryin for 2 days, nothing. Tried today with my SO’s ios 10 phone and it works great. Bug in iOS 11


(alex_bartis) #8

Did anyone try on Beta 5?


(Lutz Fricke) #9

I just switched over to iOS 11 Beta 5 from latest iOS 10 and it just worked after the first boot OF iOS 11.
I did not need to reconfigure anything or reconnecting it.


(Fabian) #10

I thing it isn’t a bug. Thing apple change the way to connect HomeKit devices to the system. And in IOS11 it will maybe never work with openhab2 sadly.


(Fabian) #11

Than don’t try to Clear Paring and reconnect openhab2 to HomeKit. I thing if you will do it, it woun’t work either.


(alex_bartis) #12

Awesome! I’ll try it tomorrow after my irlfriend with iOS 10 comes home. In case it doesn’t work for me, I won’t be stuck.


(alex_bartis) #13

Can confirm, started working again in public beta 4


(Frank) #14

Guys, have there been changes to the Karaf Console lately ? When trying to do a “smarthome:homekit clearPairings” I just receive an “unknown command” error. Looking at the list of available commands, smarthome:homekit seems to be gone entirely? (Running OH2.1 stable)

Can someone please point me to the right direction?


(Jack Wilkins) #15

Anyone got problems with the GM release of iOS 11? It was working for me fine after updating to iOS 11 initially, but I added a new light to my items today and it wasn’t showing up on HomeKit. I tried restarting HomeKit and my Raspberry Pi and there was no change, so I decided to remove the openHAB bridge and re-add it, now it can’t find the openHAB hub to re-add it to the app. Have apple changed how things are discovered? I noticed the “scan code” design has changed?


(Volker Will) #16

Can confirm that it seems impossible to pair openhab2 (OH2.1 stable) w/ homekit in iOS11 GM. Using an “old” iPad with the latest iOS 10 it worked. After it synched with iCloud openhab is now visible in iOS 11 Home.


(Gerrit) #17

Do we know when the problem would be fixed and OpenHAB is working with iOS 11?


(Martin Korsrud) #18

I have no problem pairing OH:HomeKit with IOS 11. It requires a clearing of the pairing on both ends. Delete the “home” in HomeKit on the IOS side and clear the pairing on the OH side, then pair again. The problem I’m experiencing is that I have to repeat this procedure after running for some time (usually caused by disconnecting/reconnectting the IOS device from the network).

We’ll just have to see if anyone have the time and knowledge to figure it out.


(Kevin Hab) #19

The first time I set up, it have same problem. But now I can fix this problem : ( my OpenHAB run on Ubuntu )

  • Restart your OpenHAB or restart your OS
  • Change mode homekit.json file : sudo chmod 666 /var/lib/openhab2/jsondb/homekit.json (if your OS is windows, no need to do it)
  • Log in ssh to OpenHAB and use command : smarthome:homekit clearPairings and
    smarthome:homekit allowUnauthenticated true
  • Set the interface IP for the HomeKit service is IP of your server OpenHAB
  • Then, try to pair again.
    It work fine and test with iPhone 7 iOS 11.1, iPad iOS 10.3

(Philipp) #20

here is my solved approach, had the same troubles: