HomeKit iOS 16.2 issues / dont upgrade

If you’re still running Java 11, you’ll need to use a slightly different version that I haven’t actually tested:

update org.openhab.io.homekit https://github.com/ccutrer/openhab-addons/releases/download/homekit-20221220-02/org.openhab.io.homekit-3.4.0-SNAPSHOT.jar

Did a fresh install with the Openhab 4.0 snapshot. Installed the homekit binding 4.0.0-Snapshot as pointed out by @ccutrer

All working fine (again)

Yes openhab 4.0 snapshot is working now again!

Thanks so much!

Thanks a lot - after installing this version, HomeKit worked again within seconds without doing anything else :slight_smile:

I have just registered to say thankyou for this i rebuilt it a few times was driving me nuts. :1st_place_medal::pray:

Thanks a lot!!!

Looks like Apple stopped the architecture update at the moment. Good news, maybe there will be a fast fix.

1 Like

With IOS 16.4, the architecture upgrade is back.

Has someone tried, if openhab is working fine after upgrading the home-architecture or has somebody tried it while the beta-phase of 16.4 ?


Got the same question. Don’t have the guts to try it out on my own.

Just upgraded my HomePod mini to 16.4.
I’ve never used the “Home” App with OH, because usually after a while (not sure what the trigger was), Home couldn’t control OH items anymore. I was surprised that after the upgrade the items are now back again and can be fully controlled. Guess I’ll see whether this is just temporary or the architecture is now indeed better.

1 Like

I have 2 device and OH 3.4.3:

1 with ios 16.4.1 (with upgraded home architecture)
1 with ios 16.3.0

on 16.3.0 homekit addon work fine, with 16.4.1 Im unable to add openHAB bridge: after scan HomeKit QR Code from OH and waiting several minutes it fails (I noticed that it doesn’t even ask me to add the unverified accessory)

I’m on 16.4.1 and not having any problem but haven’t migrated to the new home architecture yet (at least not that I’m aware of).

So 16.4 or 16.4.1 in itself are not causing any issue at all. Also interested in whether I should look at migrating to the new architecture or not

Yes, HomePod v16.4.1 is working fine and without any problems for me. But as everyone else I am concerned to update to the new “Home Architecture” :slight_smile:

Since upgrading to 16.5 all Osram Plugs connected to Hue Bridge are not responding anymore in OH3.4.4.
Just see that also all Homematic devices are not responding anymore as well.
Does anyone has the same issue?