Homekit Not Being Seen. My Wife is Going to Tell Me Off

Oh dear. I have rebuilt openHab on Proxmox and all working fine. I then deleted the Openhab connection to my old openhab and am trying to connect to my new one. The iphone saw the openhab and tried to connect. Took ages and then didn’ and now i can’t be seen at all. I have restarted both devices, deleted home, restarted both devices again but it still can’t see the openhab to connect to it. My wife is going to be mad as sh likes it alot.

So, I am using OpenHab 2 latest version. I have the Homekit addon added and am using the following config for homekit.cfg in services:


Redacted a bit above but that is the gist.

The weird thing is that I have an iphone 6 and connected it to test it last night and it worked so then I deleted it. My wifes phone is on a much later ios though. The most up to date I think so I am a bit worried that apple have locked it down somehow., Is this that case? I hope not.

Anyway any help with this would be greatly appreciated. I will continue to see if I can get it working although I can’t think of much more to try.

Aha this looks like an issue with my new install of openhab2. The old one is still seen by the iphoneon ios13 so thankfully it looks like openhab2 works with ios13 which is great. i have seen that you can send a command to delete pairings in openhab2 but I cant get that to work. the command that I am using thorugh putty is as follows:

smarthome:homekit clearPairings

but this doesn’t come up as a command so I suspect this is where the problems is.

I have uninstalled Homekit and re-installed to see if this works and it doesn’t as openhab still doesn’t show up. I really think I need to run that clearPairings command but it doesn’t seem a valid command.

Command still doesn’t work so not sure about that part but i have removed the homekit.json file as mentioned in the openhab page for homekit and still can’t see the openhab in homekit when I search. Oh I did reboot.

This is a known issue and the developer is working on it. Apparently it’s iOS 13 related. Search the forum and you’ll find an entire thread on the issue. We all have to be patient on this one.

Ok thanks for letting me know. I haven’t come across any iOS 13 topics yet.