HomeKit - Siri stopped working with Rollershutters

Hi everyone, hoping for some help because I can’t figure out my issue.

I am running OH3.3.0 M2 on Raspi 4. OH3 has been working fine with Homekit and Siri for more than a year. No hardware changes since last September. Suddenly, Weds (16th) or Thurs (17th) of this week Siri stopped wanting to recognize Rollershutters. We use Apple Homepods to control the house. When we ask her to open the blinds, she replies with one of these three responses

  1. “Sorry, that feature is not supported by your shades”
  2. “Hmmm, there are no accessories that support that”
  3. “Hmmm, that action is not supported by your shades”

It is possible to control the same Rollershutters and the Lamella from inside the Apple native Home app, so it appears Homekit is partially working. Also, the “Hey Siri” command does still correctly turn the lights on/off.

This is what I’ve tried

  • Looked into the logs, but no errors about this. Is there a way to turn on more Homekit specific logs? I could not find Homekit in the bundle list within the Console to do this
  • Removed and readded the HomeKit metadata for “Windowcovering”
  • Downgraded the whole system back to the stable release, but it didn’t work, so I’ve since gone back to the 3.3.0 M2.

UPDATE: Seems this issue is related to Apple iOS 15.4 update. I’ve not found a solution for it yet, but a clunky workaround seems to be using "Hey Siri, set blind position to 0% or 100% ". Still haven’t figured out how to get the Lamellas to work. Found this on REDDIT and someone there also suggested to create scenes. https://www.reddit.com/r/HomeKit/comments/te7s4u/ios_154_siri_no_longer_understands_how_to_operate/

interesting. thank you for reporting. it looks indeed as ios issue.

Thanks… ios “under the hood” change is most certainly the cause of this, just hope there is the possibility to correct this using Openhab configs. Speculating there is something with the metadata characteristics, but I just don’t have enough understanding of the Homekit config in Openhab to figure this out, yet. Would be great if the HomeKit add-on developers could look at it, I am sure it is possible to reproduce this.

Afaik all brands of accessories are affected with this issue. No matter whether they got a native support or linked via a bridge.
So I am sure Apple will fix this pretty fast with a small iOS update.

Would be wonderful to see a fix from Apple. I’ve opened an issue that was escalated immediately to their Engineering team. let see…

1 Like

Updated my devices to iOS 15.4.1 and Siri is working again. :ok_hand:t5:


I also updated my Homepods to ios version 15.4.1 this morning. Mine also started working again.

UPDATE: @dirkdirk, not sure if you have Lamella controls? One issue that has not been corrected with this update is room identification for lamellas.

Prior to the Homepod ios 15.4 update, all of the Homekit devices understood the correct locations from within the Home.app. After the 15.4 update I have to specify the room in the voice command, otherwise, it randomly opens the Kitchen blind (note: this is not the default room). However, after the 15.4.1 update, the problem was corrected for the blind controls, but the issue remains for the Lamella control. I will keep my case open with Apple Engineering and also provide updates here too.

No, no lamellas for me. Just normal roller shutters.
They work after the 15.4.1 update normal again.

Thanks, Dirk!

For anyone else that may have found your way to this thread or is paying attention to this issue, I spoke with the Apple engineering team and they confirmed the 15.4.1 update did include code fixes intended to correct this problem. I also explained the issues with the Lamellas, so at least Apple team is aware the issue was not completely corrected in the update. They simply said to look for a complete correction of this with update 15.4.2

I am going to call this issue solved since the issue is clearly not an Openhab integration-related problem.

1 Like

My roller shutter still doesn’t appear to be working with 15.4.1, also with regard to lights and switches I’m pretty certain that I used to be able to just say ‘hey Siri kitchen lights’ or ‘AV sockets’ and HomeKit would turn them on if off and off if on, but now I have to explicitly say ‘turn on ‘ or ‘turn off ’. Is anyone else seeing this or am I mistaken about previous behaviour?

Thanks Chris, something is amiss at this end then!

So, further to this, I realise that the Apple TV I was using as a hub was not running 15.4.1 and so now have the roller shutters working now. Interestingly, the issue with just saying ‘kitchen lights’ now toggles the lights as it used to , BUT, only when using Siri on the iPhone, Apple TV and iPad. It does not work on an Apple Watch (8.5.1) or a Mac (12.3.1)

Sorry, am aware this is going a little off topic.

I only recently integrated HomeKit and I can confirm that the issue persists on Apple Watch (8.5.1) where Siri reports one of the following errors:
“Sorry, that feature is not supported by your shades”
“Hmmm, there are no accessories that support that”
“Hmmm, that action is not supported by your shades”

And the only way around is to specifically say “Set blind position to x”.

On iPhone (15.4.1) works without any issues.

No worries Jorggs, it is still not working on my end either.

As mentioned prior, I escalated to Apple Engineering and sent logs. They eventually came back and said it was an issue with Openhab. I disagreed with them, so they ask me to submit feedback at Product Feedback - Apple

I tried to open the issue again, but the tech found the other issue and said he wouldn’t do it because the engineering team said it had been solved. I gave up with them…

I have the same issue with a garage door opener, works on the iPhone, but reports no accessories that support the when I try on the watch. Every. Single. Time!