HomeKit stopped working with new FritzBox 7530AX

Hello everyone,

I already spend a couple of days searching the community and google but could not really find a solution. I observe a really strange behavior of my HomeKit Add-on after I changed my router to a FritzBox 7530AX.

One of the most important features I used to use was the Push-Notification when a motion sensor was triggered. This is used to unlock the iPad which is quite cool.

After upgrading the FritzBox, I couldn’t even choose “Notification” at HomeKit for the motion sensor.
I did a lot around ClearPairings, delete Home, reboot all devices, clear cache on the iPhone and the iPad.

The bridge was found by HomeKit and could be installed, the Motion Sensor can be installed.
If I trigger the Motion Sensor manually (it’s just a Switch with HomeKit Metadata “Motion Sensor”) the App shows “Motion Detected”. But this works only for about a couple of seconds. Then, everything I do on the openhab end is well ignored. I can trigger a switch on the iPhone, this goes well into openhab and the connection is open again for a couple of seconds (for the motion sensor too).
Sometimes the changes from openhab are pushed to HomeKit after a minute or more (which doesn’t make sense for a motion sensor).

First I found an “Unknown User” Problem during pairing which I solved by changing the User at the HomeKit.json file manually.
I set the Log Level to TRACE and the logs seems quite free of errors:

I updated to Openhab 4.0.2 which didn’t solve the problem.

Next step was checking if openhab publishes it correctly, it seems to be ok:

(can be embedded in one of the next posts as I’m a new user)

Apart from the hostname which I guess the new FritzBox just added something to the hostname which annoys me (that “-fritz-box.local”) but doesn’t seem to be the problem.

Does anybody of you have experienced a similar problem?
I really think it is more the FritzBox causing trouble instead of openhab, but any idea?
This is really driving me crazy as all the logs tell me, that it is working but it is not :grinning:


I experienced also some issues when switching to my new FritzBox 7530AX. The issues I have are related to DNS resolution.
Openhab (4.0.3.-1) running on a raspberry pi was not reachable via the hostname even if the IP was still available. The connection via IP worked fine.
I haven’t worked this out finally but I thinks it’s somehow DNS related.
When trying to re-install I found the message in the logs that another mDNS stack is running.