Homekit tagging - missing EOF in items files

Just added homekit/homebrige and with two temps able to get a reading off them.

But if I try to add something else, the items file complains (both in karaf and designer) that EOF missing at [

Switch gf_cupboard1_fan “Fan Control [%s]” (g_cupboard,g_switchpersist) {mqtt=">[frodo:cupboard/fan:command:ON:1],>[frodo:cupboard/fan:command:OFF:0],<[frodo:cupboard/fanstate:state:default]"} [“Switchable”]

Any guidance?

1 Like

Compare your working two temp item with your failing 3 temp item. Anything different?

I would think the complaint above is about the ["Switchable"] term.

I’ll do that.

One thing not clear in the docs is on th eopenhab homekit.cfg, the interface setting.

Is this the interface to use on my openhab machine to find the homebridge (which is on another machine).

Or are these two supposed to be together on the same machine?

You’re right, the doc isn’t very clear. Unfortunately I don’t know the answer.

try putting the ["Switchable’] tag before the mqtt device string.

ie :

Switch gf_cupboard1_fan "Fan Control [%s]" (g_cupboard,g_switchpersist)  ["Switchable"]  {mqtt=">[frodo:cupboard/fan:command:ON:1],>[frodo:cupboard/fan:command:OFF:0],<[frodo:cupboard/fanstate:state:default]"}

this seems to work…I noticed with the working ones, they were a dummy item with no binding as they took as update from a rule.

Last question, for zwave items how can I homekit those, since they don’t have an items file?

You may have to create a ZWave.items config file(s) for them also.
I don’t know if it is possible to add a (homekit) tag to an auto-created item from PaperUI… (maybe it is)