Homematic Binding and CCU1 timeout

I recently installed OpenHAB 2 after staying a long time with OpenHAB 1. With OH1.x I had also a connection with the CCU1 (42 devices) and it worked after setting the timeout to 60s. With OH2 I have no chance - Initalization is successful but after 30 secs the CCU1 crashes. I have found few topics here with similar issues but no real solution. Is it simply not possible with CCU1? I’m just wondering because it worked with OH1.

Hi Sven,

which OH version are you using? If you are using 2.1 you should try a 2.2 snapshot version. As far as I remember there have been some changes in this version regarding CCU1 support.

Hi Martin,
I’m using the 2.2.0 snapshot (was automatically installed during the setup on my Synology Diskstation), I believe it is the current version.

So maybe @gerrieg has an idea. I am not familiar with the CCU1 because I started with CCU2.

That would be great.

I never owned a CCU1, but with the help of some users i implemented CCU1 support in the binding. OH1 and OH2 uses completely different methods to connect to the CCU. In OH1, the binding uses some TCL-Scripts, the OH2 binding uses the official Homematic API. But with the API, there are much more calls necessary to communicate with the CCU. Maybe this is too much or too fast for a CCU1.

So can you please switch the binding to TRACE mode and send me a full startup log until the CCU crashes. Maybe i find something in the logfiles.

Hello @gerrieg,
ok, I will do this tomorrow.

Is it possible to send the logs as a personal message?

Thanks for the trace log!

First of all, you are using the snapshot version In the logfile, i found a NumberFormatException that has already been fixed in a later snapshot version.

Regarding the main problem … well, the new connection tracker in the 2.2 snapshot does not work with a CCU1, the API does not support the ping method :frowning: Either the CCU1 crashes because the method does not exist (although it send a error message back), or the binding commands are too fast. I think i must implement a special CCU1 connection tracker and also a delay between the calls. I hope this will fix it. I will do it soon and let you know.

If you like, you can try the 2.1 version in the meantime. There is an older connection tracker implemented.

Thanks for digging into this issue.
I will try the 2.1 version in the meantime. Maybe the time has come to move to a CCU2.

I fixed the connection tracker now. https://github.com/openhab/openhab2-addons/pull/2785

Once it has been merged, can you please try it again and send me the TRACE log?

ok, I will try as soon as possible. Yesterday I tried to downgrade to 2.1.0, which destroyed my setup. I did now a clean install of 2.1. I did a backup before so I should be able to restore everything.
Can I use the 2.1.0 base installation with newer bindings or do I have to use the same version for everything?

I just tested it with the 2.1.0 Build, here the homematic binding seems to work (I will see tomorrow if the CCU1 hangs after some time).

what I can say so far is, the at least the 2.1.0 version works table with the CCU1. After 1 day uptime there is no negative impact. I will try again with the 2.2.0 version as soon I have the time and keep you updated.

Thank you for the info, it really seems to be the connection tracker. OH 2.2 build 1065 contains the fix. Feedback would be great if you have time.

Now I had OH2 (2.1.0) running for about 1 week, tonight the CCU1 crashed. I will try to update to 2.2 and test again.

Just a short update. I’m using a Synology as server and tried to upgrade from 2.1.0 to the latest 2.2 Snapshot which was not a good idea. It killed my whole Syno system, so I had to completely reinstall it. So it will take some time until I’m ready to test.

Now after reinstalling my Syno i did some tests with installing OpenHAB2 2.2.008 (which I suppose does not include the updated homatic binding). After enabling the binding and addign the CCU1 it freezes after two minutes. I would like to test it with the new homematic binding build you made but how can I update just the binding? With OH1.x it was quite easy but with 2.x I need some help.

I would like to give you a short update. After doing a clean install of OH2.2 the issue with Homematic binding and the CCU1 remains the same. After configuring the binding, discovery runs and afterwards the CCU freezes. Is there anything special I have to configure?
But for now I would like to wish you a merry christmas!